0

/etc/exim4/update-exim4.conf.conf

dc_eximconfig_configtype='smarthost' # was local
dc_other_hostnames='' # was mini31
dc_local_interfaces='127.0.0.1 ; ::1'
dc_readhost='mini31'
dc_relay_domains=''
dc_minimaldns='false'
dc_relay_nets=''
dc_smarthost='send.one.com:465' # Yes, two colons.
CFILEMODE='644'
dc_use_split_config='false'
dc_hide_mailname='true'
dc_mailname_in_oh='true'
dc_localdelivery='mail_spool'

/etc/exim/passwd.client

target:send.one.com:[email protected]:MyTopSecretPassword

/etc/email-addresses

localusername:[email protected]

/var/log/exim4/mainlog

2022-07-10 23:03:49 1oAf1p-0004w0-GD <= [email protected] U=rwb P=local S=355
2022-07-10 23:03:49 1oAf1p-0004w0-GD H=send.one.com [2a02:2350:5:20e::2] Network is unreachable
2022-07-10 23:03:49 1oAf1p-0004w0-GD H=send.one.com [2a02:2350:5:20e::1] Network is unreachable

or sometimes

mini31 # tail /var/log/exim4/mainlog
2022-07-10 23:05:28 1oAf1p-0004w0-GD Spool file is locked (another process is handling this message)
2022-07-10 23:05:28 End queue run: pid=19276
2022-07-10 23:08:49 1oAf1p-0004w0-GD H=send.one.com [46.30.211.141]: SMTP timeout after initial connection: Connection timed out
2022-07-10 23:08:49 1oAf1p-0004w0-GD == [email protected] R=smarthost T=remote_smtp_smarthost defer (110): Connection timed out H=send.one.com [46.30.211.141]: SMTP timeout after initial connection
2022-07-10 23:10:58 exim 4.92 daemon started: pid=19694, -q30m, listening for SMTP on [127.0.0.1]:25 [::1]:25
2022-07-10 23:10:58 Start queue run: pid=19695
2022-07-10 23:10:58 1oAf1p-0004w0-GD == [email protected] R=smarthost T=remote_smtp_smarthost defer (-53): retry time not reached for any host for 'rwb.me.uk'
2022-07-10 23:10:58 End queue run: pid=19695
2022-07-10 23:11:26 1oAf9C-00057u-P5 <= root@mini31 U=root P=local S=330
2022-07-10 23:11:26 1oAf9C-00057u-P5 == [email protected] R=smarthost T=remote_smtp_smarthost defer (-53): retry time not reached for any host for 'rwb.me.uk'

** Mail delivery failed: returning message to sender**

...
  [email protected]
    host send.one.com [46.30.211.141]
    SMTP error from remote mail server after pipelined end of data:
    530 5.7.0 Authentication required
...
mini31 # mailq
12m   355 1oAf1p-0004w0-GD <[email protected]> (rwb)
          [email protected]

 4m   330 1oAf9C-00057u-P5 <root@mini31>
          [email protected]

Question

WTF is going on and why isn't it working?

One.com seem to say port 465 and SSL/TLS. Do I need to enter SSL/TLS into exim4 somehow? I'm pretty sure they need the from address to be [email protected] -- do I need to set that somehwere?

Do I need to remove junk from mail1q?

1 Answer 1

0

Not target: in passwd.client.

Use satellite instead of smarthost because no local mail is required -- everything should go to the real address.

Changed dc_other_hostnames back to mini31 and dc_readhost to omething.com. Don't know why; it's unclear what these do.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .