0

I was about to do some changes to the php.ini and when I checked the service I found out that is was in a failed state. Stopping and starting the service didn't do the trick. The most helpful log entry was this one from the php8.0-fpm.log file:

ERROR: fork() failed: Resource temporarily unavailable (11)

At first I thought I hited some PID limit but:

❯ ps -eLf | wc -l
130

❯ sysctl kernel.pid_max
kernel.pid_max = 32768

So that is not the case.

I checked the php.ini of fpm but I couldn't find anything wrong.

Here is some output that might help(I searched for all them extensively but couldn't find any solution)

❯systemctl status -l php8.0-fpm
php8.0-fpm.service - The PHP 8.0 FastCGI Process Manager
   Loaded: loaded (/lib/systemd/system/php8.0-fpm.service; enabled; vendor preset: enabled)
   Active: failed (Result: protocol) since Thu 2022-07-14 23:07:24 CEST; 20min ago
     Docs: man:php-fpm8.0(8)
  Process: 6960 ExecStart=/usr/sbin/php-fpm8.0 --nodaemonize --fpm-config /etc/php/8.0/fpm/php-fpm.conf (code=exited, status=0/SUCCESS)
  Process: 7126 ExecStopPost=/usr/lib/php/php-fpm-socket-helper remove /run/php/php-fpm.sock /etc/php/8.0/fpm/pool.d/www.conf 80 (code=exited, status=0/SUCCESS)
 Main PID: 6960 (code=exited, status=0/SUCCESS)
❯ journalctl -b -u php8.0-fpm
-- Logs begin at Fri 2022-07-15 00:45:44 CEST, end at Fri 2022-07-15 21:56:46 CEST. --
Jul 15 xxxxxx systemd[1]: Starting The PHP 8.0 FastCGI Process Manager...
Jul 15 xxxxxx systemd[1]: php8.0-fpm.service: Failed with result 'protocol'.
Jul 15 xxxxxx systemd[1]: Failed to start The PHP 8.0 FastCGI Process Manager.
❯cat php8.0-fpm.log
NOTICE: fpm is running, pid 1794
ERROR: fork() failed: Resource temporarily unavailable (11)
NOTICE: exiting, bye-bye!
❯ php -v
PHP 8.0.20 (cli) (built: Jun 14 2022 10:25:42) ( NTS )
Copyright (c) The PHP Group
Zend Engine v4.0.20, Copyright (c) Zend Technologies
    with Zend OPcache v8.0.20, Copyright (c), by Zend Technologies

I am running Debian 10 and apache and no other php version is installed.

1 Answer 1

1

What happened is that after an apt upgrade the php-fpm.conf file was deleted.. I made a new file with the default conf, but the apt upgrade was still failing to update with the error:

installed php8.0-fpm package post-installation script subprocess returned error exit status 1

I removed the package with:

sudo apt remove --purge -y php8.0-fpm

and reinstalled with

sudo apt install php8.0-fpm

then activated the configuration with

sudo a2enconf php8.0-fpm

and finally reloaded apache:

sudo systemctl reload apache2

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .