0

I want to mount on demand using autofs or systemd automount. But I can't get neither of it to work.

With autofs. I have this file

cat /etc/auto.weed

/mnt/data -fstype=weed,allow_other,rw,filer=10.104.0.5,filer.path=/data

I try to change -fstype=weed to -fstype=fuse but still not work. I don't know how to get the right config

With systemd automount. I have this config in fstab

fuse /mnt/data weed noauto,x-systemd.automount,_netdev,filer=10.104.0.5:8888,filer.path=/data 0 0

When I run systemctl start mnt-data.automount It return error "No such device" when I try to access /mnt/data. But I run mount and it work normal

If someone how to make it work. Please give some pointer Thank you

1 Answer 1

0

ln -s /sbin/weed /sbin/mount.weed

fuse /data fuse.weed defaults,_netdev,x-systemd.automount,filer='xxx.xxx.xxx.xxx:8888,xxx.xxx.xxx.xxx:8888,xxx.xxx.xxx.xxx:8888',filer.path=/ 0 0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.