1

Starting from 23 July 2022 WSUS synchronization started failing with error: "A dependency of the update was not found on the server and was not provided by the upstream server.".

WSUS does not have upstream server, it syncs from Microsoft.

When I open synchronization report - there are IDs of updates, that that fail with this error. The first ID is 3435b461-7ec5-4ee6-af82-4682636e12cb : Revision 100

When I try Get-WsusUpdate -UpdateId 3435b461-7ec5-4ee6-af82-4682636e12cb I get error: The specified item could not be found in the database.

Searching in Google or www.catalog.update.microsoft.com by UpdateID also give no results.

How to resolve this synchronization error? How can I get information about this Update?

Tried updating WSUS server itself - the error persist.

Tried running WSUS cleanup wizard. While running cleanup wizard WSUS console crashed. After WSUS console crashed I waited about 1 hour thinking that cleanup wizard still running in background. After 1 hour I rebooted WSUS and run synchronization, but the error persist.

1
  • show the WSUS update settings, the server version, the ressources and the IIS settings pool, which sql is used for it?
    – djdomi
    Commented Aug 7, 2022 at 17:37

1 Answer 1

2

The workaround looks to be documented at the below link but no word on if Microsoft is going to address this upstream at the time of posting.

https://docs.microsoft.com/en-us/answers/questions/944674/wsus-sync-failures.html

"The error is with the "Windows Insider Dev Channel" product. On all four WSUS servers that I take care of, a synchronization error started to appear and all I had to do was to disable this product." - JanaJaro-4745

Unchecking the "Windows Insider Dev Channel" product has worked for a number of people on that article including myself.

1
  • Yes, this workaround actually works. No more synchronization erros.
    – Link
    Commented Aug 8, 2022 at 21:09

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .