-1

Okay, so you would think my client wanting to get an iPad online via ethernet would be simple and straight-forward way for me to earn $20. When I arrived, this is the setup I found:

"The Setup"

The iPad Pro (model MQDX2LL/A, with software version 14.4.1) cannot simply be plugged into the GS108PE ethernet switch because an error message occurs on the iPad when you plug in the lightning adapter: "The attached accessory uses too much power."

Upon arrival, the Amazon Basics USB Hub was not plugged into an outlet, and I found that plugging in the 5-Volt DC stopped that error message from popping up; apparently, there is a power requirement to send data of a certain quantity through the camera adapter (so I read online). With sufficient power, under the iPad's Settings the "Ethernet" option appears, as exemplified here:

iPad Pro Ethernet Screen

The problem I faced then was that something seemed to be assigning the iPad a 169.254.xxx.xxx IP address, which is the dummy value for "bad connection" or something of the sort.

Periodically, after restarting the EU2251 modem, a real IP address of 192.168.x.x would appear, but would suddenly and unexpectedly revert back to the default dummy address 169.254.xxx.xxx after some time and without notice. I tried "hard-coding" or manually setting the IP address, but it wasn't clear this was working. Problem 1: How to secure a stable IP address.

Now, sometimes when I had a real IP, I would test a website in Safari, but I always received a message along the lines of "The site can't be reached" with subtext of "www.X.com's server DNS address [or was it IP address?] could not be found".

I found online one forum suggesting manually setting the DNS to Google's like so:

Google's DNS Settings

However, this didn't resolve the issue; rather, attempting to load a website would simply hang for almost a minute or two before seemingly timing out, whereas before a website could not be reached in just a few seconds. Problem 2: How to access the internet.

So that's the situation.

With so many moving parts here, I'm not really sure what the next step in trouble-shooting this might be. There's the modem, switch, and desktop that could be configured; there's hardware and cabling limitations that could be preventing data transmission or holding compatibility-issues; there's the iPad itself.

I'm wondering if there's a setting upstream from the iPad that I need to configure to whitelist, acknowledge, or route it. Do I need to hard-code/manually enter the IP address, subnet mask, and router in the iPad settings rather than relying on its default "Automatic" detection ? Am I using the wrong ethernet port in the switch (I've tried multiple)? Networking is not my forte, yet as seen, this is a relatively unusual situation.

What do you think ?

(P.S.- To be sure: the internet works fine from the desktop, and the iPad can connect to the modem/internet via Wi-Fi.)

Reference: Why not just use an Ethernet-to-Lightning adapter? "Not enough power."

1 Answer 1

1

169.254.xxx.xxx is a self-assigned link-local address that you see only if IPv4 address assignment via DHCP was not successful. Read it as “nobody has assigned me an IPv4 address”.

I suspect one of the very high number of connectors (8 if I counted correctly) between the iPad and the modem causes problems. Get an Ethernet to Lightning adapter (e.g., from Belkin), and keep the USB hub out of things. (USB hubs are very complex devices and endless sources of problems.)

3

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.