I am hitting the same error in trying to backup a mongo stand-alone database:

Failed: error connecting to db server: server returned error on SASL authentication step: BSON field 'saslContinue.mechanism' is an unknown field.

Most of the other answers, point to adding --authenticationDatabase=admin, but this did not solve it for me.

I have tried basically the same thing in a few different ways, they all give the same error:

# mongodump --host -u "<USERNAME>" -p '<PASSWORD>'  --authenticationDatabase "admin"
# mongodump --host -u "<USERNAME>" -p '<PASSWORD>' --out /var/backups/mongobackups/$(date +'\%y-\%m-\%d') 
# mongodump --host --username <USERNAME> --password '<PASSWORD>' --authenticationDatabase admin --db <DBNAME> --out /var/backups/mongobackups/$(date +'\%y-\%m-\%d') 
# mongodump mongodb://<USERNAME>:<PASSWORD>@
# mongodump --host= --port=27017 --username=<USERNAME> --authenticationDatabase=admin --out=/var/backups/mongobackups/$(date +'\%y-\%m-\%d') 

My password does include a special character, an @ sign.

The config is pretty vanilla:

#mongodb.conf - generated from Puppet
#System Log
systemLog.path: /var/log/mongodb/mongodb.log
systemLog.destination: file
systemLog.logAppend: true
systemLog.quiet: false
systemLog.verbosity: 2

#Process Management
pidFilePath: /var/run/mongod.pid

storage.dbPath: /var/lib/mongodb

security.authorization: enabled


I can succesfully enter the shell by running:

mongo -u <USERNAME> -p <PASSWORD><DBNAME> --authenticationDatabase "admin"

Version info:

# apt list --installed | grep mongo
mongo-tools/focal,now 3.6.3-0ubuntu1 amd64 [installed]
mongodb-org-server/focal,now 5.0.6 amd64 [installed,upgradable to: 5.0.10]
mongodb-org-shell/focal,now 5.0.6 amd64 [installed,upgradable to: 5.0.10]

# mongodump --version
mongodump version: built-without-version-string
  • What are the versions of MongoDB and mongodump? Aug 14, 2022 at 10:59
  • Updated to add version info
    – Werner
    Aug 15, 2022 at 6:24
  • I recommend downloading the version from MongoDB's site and not from apt. Aug 15, 2022 at 6:27

1 Answer 1

get the "mongodb-database-tools"  after update to this version error was gone

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.