0

I'm using a Dell PowerEdge R820 with PERC H710 adapter

I had RAID 0 configured across two 1TB SSDs, Drive A and Drive B. I recently bought a 5TB HDD, Drive C. Today, I was attempting to create a RAID 0 volume for Drive C in the LifeCycle controller, using the "configure raid" option under the "Home" tab. I set up configuration for Drive C, and finalized the changes not realising that this overwrites my existing configuration for Drives A and B. Drives A and B contain(ed?) my OS, and on rebooting the server, no bootable devices were found. I looked in the BIOS but only saw Drive C configured for RAID. Then, I went into the RAID Controller BIOS and recreated the Virtual Disk for Drives A and B, without initialising them, which the BIOS told me would preserve the data on them. I set this new volume to be the boot volume, and rebooted, but I was met with the same message. Is my data gone?

1
  • Curiously enough, I once recovered an array successfully by following exactly the same procedure on LSI MegaRAID. PERCs are rebranded LSIs, they are controlled with the same utilities, megacli or storcli, so it should be the same. Can you try to boot some other medium (e.g. USB flash) to see what's on disks? If you use UEFI, you might just need to re-create the boot entry. Aug 16, 2022 at 5:38

2 Answers 2

1

you can access the BIOS PERC card, recreate your old Virtual Disk and if nothing else was written on the Raid0 you could be able to access data

3
  • I'm marking this as the correct answer in the hope that it works for someone else, I tried some things along these lines but in the end I decided it would probably take less time to just reinstall the OS as there wasn't loads of data on there anyway. I'm switching to an NVMe SSD for my OS install to reduce the risk of things going wrong with my RAID in the future. Thank you for your help Aug 17, 2022 at 4:44
  • This might work on a RAID 0 but a word of caution to the broader audience - RAID initialization kicks off immediately after virtual volume creation and destroys the pre-existing data. Even for RAID 0 though I would be surprised if this ever worked - maybe? In theory it might but I would be surprised Aug 25, 2022 at 18:32
  • Hi @GrantCurell, the initialization the PERC does by default when you create a VD is a background initialization which in fact is a check consistency process, it is not going to initialize the Virtual Disk so if by mistake you delete the VD, creating again the same VD with the same parameters/size will give you access to the VD information, that of course keeping in mind that nothing else happens between you delete the VD and you create it again.
    – Coré
    Aug 27, 2022 at 7:48
0

Correct - if you inadvertently deleted those RAID volumes to create the new one they are forever gone ☹️

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .