I've tried searching for this answer, but haven't found anything elegant.

I have numerous servers in a colo that is in another state. I need to find a way to check that the servers have RAID-1 on them, so that I can determine if they were setup correctly by my colo.

df -h shows: Filesystem Size Used Avail Use% Mounted on /dev/mapper/VolGroup00-LogVol00 442G 1.5G 418G 1% / /dev/sda1 99M 19M 75M 20% /boot tmpfs 4.0G 0 4.0G 0% /dev/shm

however as CentOS uses LVM by default, this doesn't indicate if a RAID-1 is present.

it is supposed to be a software raid, so I'm pretty sure there should be a way to check.



cat /proc/mdstat will give you raid usage on your machine

dmesg | grep raid will tell you if raid is enabled in your kernel

  • /proc/mdstat wasn't useful to me for some reason, but the dmesg | grep raid was certainly where I started. Thanks. – Tedd Johnson Feb 8 '10 at 20:25

I think I found the answer right after I asked.

dmraid -r should do what I'm looking for.

  • 1
    I tried that on a few of my software raid machines and it says 'no raid disks' while cat /proc/mdstat does tell me about the raids. – toppledwagon Feb 8 '10 at 21:43
  • strange, that's completely backwards for me. I found out from my colo guy that he installed the raids wrong anyways – Tedd Johnson Feb 8 '10 at 22:06


when i try this command

[root@localhost ~]# dmraid -r

My result is :

[root@localhost ~]# dmraid -r /dev/sda: isw, "isw_dhefccahba", GROUP, ok, 976773165 sectors, data@ 0 /dev/sdb: isw, "isw_dhefccahba", GROUP, ok, 976773165 sectors, data@ 0

What is the meaning of above results

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.