What I want to do

I want to log in to IPMI through the web interface. The motherboard is from Supermicro and the product name is X11DPG-QT. I am able to access the login webpage, but I get the error message: "Invalid Username or Password". However, the login works through SSH: ssh -l ADMIN c602-ipmi.

What I have tried so far

I had a look and there is a tool from Supermicro to manage/adapt the configuration of IPMI (including changing the user's password): https://www.supermicro.com/en/support/resources/downloadcenter/smsdownload

Through the tool (IPMICFG_1.33.2_build.220126), I can manage the existing user accounts. For example, list them:

[c602] ~  # ./IPMICFG-Linux.x86_64 -user list
Maximum number of Users          : 10
Count of currently enabled Users : 1
User ID | User Name        | Privilege Level | Enable
------- | ---------        | --------------- | ------
      2 | ADMIN            | Administrator   | Yes

I tried to update/change the password with the following command:

[c602] ~  # ./IPMICFG-Linux.x86_64 -user setpwd 2 a_5QWPMICBA

Which seems to work; however, I still cannot log in through the web interface. It still says “Invalid Username or Password”. The new password works for the SSH connection.

In addition, I checked that the hostnames (SSH vs. HTTP) resolve to the same IP address. I also powered off the entire server and unplugged all cables for a few minutes.

My Question

What do I miss? Thank you!

  • There is a whole long post on this topic here: serverfault.com/questions/85042/…
    – yield
    Commented Aug 26, 2022 at 12:29
  • Thanks for your reply. I am aware of that topic. I went through it and it does not help. My issue described above is not mentioned at all. As described, changing the password works partly (for SSH). So the issue actually does not seem to be the password itself. If I miss something, please point me to it. Thank you!
    – YuTendo
    Commented Aug 26, 2022 at 13:17
  • Try https proto
    – gapsf
    Commented Aug 27, 2022 at 13:45
  • I tried, but it did not work.
    – YuTendo
    Commented Aug 29, 2022 at 7:06

1 Answer 1


I contacted the SuperMicro Support and explained to them the problem. After checking a couple of things (e.g., web browser compatibility), they recommended me to perform a factory reset:

./IPMICFG-Linux.x86_64 -fd

This solved the issue. After the factory reset, I was able to log in to the IPMI web interface (with the default login credentials). I changed the password through the web interface to the one I had before. It still works (HTTPS and SSH).

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .