One of our Supermicro servers won't boot from the virtual drive on a MegaRAID SAS 9361-8i after a power outage.

It can still boot from a USB stick without trouble, all hard drives and file systems seem to be intact. The correct drive is not shown as an option to select for booting in BIOS. I have tried resetting both BIOS and the RAID controller BIOS. In the RAID controller BIOS the "Enable controller BIOS" box found under Ctrl Mgmt is checked.

Messages that might be helpful:

During a boot attempt, the following is displayed: "1 virtual drives found on the host adapter, 0 virtual drives handled by bios"

In BIOS Event logs, there is an error with the code "EFI 03051002" and the description "DXE BS driver Unrecognized".

I also briefly tried to manually select the boot location in the UEFI shell but was quickly thwarted by not being able to read the drive here either, i.e. "Map: no mapping found."

Any help in diagnosing or fixing the error, or determining what needs to be replaced would be highly appreciated!

System information:

BIOS - "version 2.18.1264. Copyright (c) 2018 American Megatrends, Inc."

RAID controller - "AVAGO MegaRAID SAS 9361-8i"

RAID controller BIOS version - ""

2 Answers 2


Much trouble shooting and many failed attempts later, the server is working!

What finally fixed it:

In BIOS under

Advanced > PCIe/PCI/PnP Configuration

The slot where the RAID controller was plugged in:


was set to [Legacy]

I changed this from [Legacy] to [EFI], and then BIOS could find the virtual drive and boot normally.

  • Same thing on my SuperMicro workstation with my LSI 9266-8i. [Legacy] can access the web bios and show the POST output before booting, and [EFI] allows exporting the arrays to EFI booted systems.
    – ZeWaren
    Jan 11 at 9:01

Not exactly an answer to your question but possibly a workaround:

Since the data can still be read after booting from a live disk, you could try installing grub on a different drive (that is recognized while booting). Maybe https://wiki.debian.org/GrubEFIReinstall could be helpful.

  • Thank you for the answer! It's finally working, else I would have come back to try this.
    – frogsicle
    Oct 27, 2022 at 11:27

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .