0

SYSTEM INFORMATION
OS type and version: Debian Linux 10.13 Webmin version: 1.941 Virtualmin version: 6.08

In the past I had no problems sending and receiving mails on my virtual domains I think all got started after I upgraded from Jessie to Buster but Im not sure.

Here is my postfix conf:

# See /usr/share/postfix/main.cf.dist for a commented, more complete version

# Debian specific:  Specifying a file name will cause the first
# line of that file to be used as the name.  The Debian default
# is /etc/mailname.
#myorigin = /etc/mailname

smtpd_banner = $myhostname ESMTP $mail_name (Debian/GNU)
biff = no

# appending .domain is the MUA's job.
append_dot_mydomain = no

# Uncomment the next line to generate "delayed mail" warnings
#delay_warning_time = 4h

readme_directory = no

# TLS parameters
smtpd_tls_cert_file=/etc/ssl/certs/ssl-cert-snakeoil.pem
smtpd_tls_key_file=/etc/ssl/private/ssl-cert-snakeoil.key
smtpd_use_tls=yes
smtpd_tls_session_cache_database = btree:${data_directory}/smtpd_scache
smtp_tls_session_cache_database = btree:${data_directory}/smtp_scache

# See /usr/share/doc/postfix/TLS_README.gz in the postfix-doc package for
# information on enabling SSL in the smtp client.

inet_interfaces = all
inet_protocols = all
alias_maps = hash:/etc/aliases
alias_database = hash:/etc/aliases
myorigin = /etc/mailname
mydestination = ns6707031.ip-43-45-56.eu, localhost
mynetworks = 127.0.0.0/8 [::ffff:127.0.0.0]/104 [::1]/128
mailbox_command = /usr/bin/procmail-wrapper -o -a $DOMAIN -d $LOGNAME
mailbox_size_limit = 0
recipient_delimiter = +
virtual_alias_maps = hash:/etc/postfix/virtual
sender_bcc_maps = hash:/etc/postfix/bcc
home_mailbox = Maildir/
smtpd_sasl_auth_enable = yes
smtpd_sasl_security_options = noanonymous
broken_sasl_auth_clients = yes
smtpd_recipient_restrictions = permit_mynetworks permit_sasl_authenticated reject_unauth_destination
allow_percent_hack = no
smtpd_sasl_authenticated_header = yes

A part from mail.log when I send myself an email from another mail.:

Sep 30 11:11:31 tz3145073 postfix/local[10812]: DA843E0086: [email protected], orig_to=<[email protected].>, relay=local, delay=100, delays=0.08/0.03/0/100, dsn=2.0.0, status=sent (delivered to command: /usr/bin/procmail-wrapper -o -a $DOMAIN -d $LOGNAME)
Sep 30 11:11:31 tz3145073 postfix/qmgr[22689]: DA843E0086: removed

Here is netstat stats:

netstat -tuplen | grep 25
tcp 0 0 0.0.0.0:25 0.0.0.0:* LISTEN 0 123456789 54533/master
tcp6 0 0 :::25 :::* LISTEN 0 123458468 54533/master

Update: I can see the emails on maildir: /home/domainname/homes/username/Maildir

But why not on Thunderbird or Roundcube inbox?

I appreciate any hints!

2
  • Check you maildir for mail you sent. Log says mail delivered to LDA (procmail)
    – gapsf
    Commented Oct 5, 2022 at 14:47
  • @gapsf you are right actually, I can see them in maildir but why not in Roundcube or Thunderbird?
    – Anarkie
    Commented Oct 16, 2022 at 21:18

1 Answer 1

0

Finally I found the problem... the Dovecot conf file mail location was different:

# mail_location = mbox:~/mail:INBOX=/var/mail/%u

above is ex setting, below new setting

mail_location = maildir:~/Maildir

What could have changed Dovecot setting or why would they be different from Postfix?

1
  • You should not answer your question with a new question.
    – mailq
    Commented Oct 18, 2022 at 15:15

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .