0
  • OpenVPN version is: OpenVPN 2.4.8 x86_64-w64-mingw32
  • Topology is: Machines at VirtualBox, server and client

I know there are many posts about this question, but so far, I could not find the answer.

  • OpenVPN it does work in LAN flawlessly
  • Port forward on the router has been done.
  • the firewall has been disabled at the server and client

Those are the logs

**from the server: ** [LOG FROM SERVER] 1

**from the client: ** [LOG FROM CLIENT] 2

There is something in the server logs, I cannot really understand, the reason it does not show the default port (as it was configured at both server and client conf files) and every single time it does get a connectión, the port changes it

Any help will be very welcome

Gracias

2
  • Hi Alejandro and welcome to serverfault, please be advised that serverfault is for professional server administration and not home or personal play setup. In those cases SE sites like superuser are more suitable. That being said I can't tell if this setup is for a work network or not but timestamps on your logs (half past nine on a saturday evening) point toward a home setup :-)
    – ojs
    Oct 9, 2022 at 8:57
  • Thank you for your help. I´ll use superuser. sorry for any inconvenience Oct 9, 2022 at 10:21

1 Answer 1

0

The ports in your logs that you are confused about are the ports that your client is sending data out on and that can change as the client wishes. So the client is sending out data on port 54599 to server on port 1194, but fails and then send again on another port. This is normal. Your problem is related to TLS so my guess is that you didn't use the right certificate files in setting up your VPN connection. Go over the files again and make sure you understand the difference between all of them, it can be a bit difficult to understand which file to use where.

1
  • Thanks for your help. I´ll try to go all over again. As i was advice i´ll open a post at superuser. i´ll add the link here when it is made Oct 9, 2022 at 10:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.