I have 4 VMs running Ubuntu within Parallels (host machine is OS X). I am trying to set up SSH so that I can SSH into them, but I can't connect to them individually. They are all reporting the same IP with ip -a. I've tried it with both the Shared and Bridged networking modes, and get the same thing both times. They all have unique hostnames, but if I try to connect via hostname from OS X, the hostname won't work ("could not resolve hostname | nodename nor servname provided, or not known"). If I connect with IP, I can successfully log into the 1st of 4 VMs (confirmed by returning hostname once I'm logged in), but that's the only one I can connect to.

I tried setting up IP port forwarding under Parallels -> Preferences -> Network -> Shared, but when I put the port forwarding rule in for a specific port (e.g., 2200), I can't connect to that port from the host box.

How can I configure the 4 VMs with unique IPs so that I can SSH into them individually? Many thanks for your help.

1 Answer 1


Did you try to connect with the hostname as found in the etc/hosts file try ping it first with ping ubuntu20.shared

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.