hello so i have a ubuntu hpc cluster and i got a problem with storage

whenever i try to access the storage from my compute nodes i cant i keep getting this error

mount:mounting or /installer_root
failed :operation not supported trying to mount again 

i managed to get one running but it cant access the storage and when i type lsblk i dont get anything under sdb

root@omics-master:/# lsblk
sda                8:0    0 446.6G  0 disk
├─sda1             8:1    0     1G  0 part  /boot
├─sda2             8:2    0    16G  0 part  [SWAP]
└─sda3             8:3    0 429.6G  0 part  /
sdb                8:16   0 116.4T  0 disk
└─mpatha         253:0    0 116.4T  0 mpath
sdc                8:32   0 116.4T  0 disk
├─mpatha         253:0    0 116.4T  0 mpath
├─omics-homes    253:1    0  26.2T  0 lvm   /omics/homes
├─omics-tools    253:2    0     1T  0 lvm   /omics/tools
└─omics-projects 253:3    0   5.2T  0 lvm   /omics/projects

and when i type lvdisplay ig get this error

root@omics-master:/# lvdisplay
  WARNING: Not using device /dev/mapper/mpatha for PV 2CetpS-708F-cB6A-m5Vd-gKkl-oEex-8x1tWI.
  WARNING: PV 2CetpS-708F-cB6A-m5Vd-gKkl-oEex-8x1tWI prefers device /dev/sdc because device is used by LV.

and when i type multipath -ll i got this

root@omics-master:/# multipath -ll
mpatha (3600c0ff00051423aaf6dcd5e01000000) dm-0 DellEMC,ME4
size=116T features='0' hwhandler='1 alua' wp=rw
|-+- policy='service-time 0' prio=50 status=active
| `- 16:0:0:0 sdc 8:32 active ready running
`-+- policy='service-time 0' prio=10 status=enabled
  `- 15:0:0:0 sdb 8:16 active ready running

any clue where i can start the last thing i did was making a new group and thats all and when i restarted all nodes none of them worked do i need to remount it or do something like that

1 Answer 1


As root, run:

vgimportclone /dev/sdb --basevgname mpatha

On my system, I had to import a snapshot with the vgimportclone command, and it hangs, and I have to CTL+C to cancel out of it. First time I ran it, I ran it again. It hung again. But, then ran vgscan, and instead of errors, I saw a renamed vg. Not sure if it will hang on your system, I am using Oracle Linux 8.

You should see mpatha was renamed to mpatha1 on the imported vg.

Note, this will permanently alter the disk uuid of the import, as evidenced by lsblk -f. Which means to mount it on the original (or any other) system, you will have to specify the new vg name or uuid, depending on how you build your fstab file.

The new vg mpatha1 will not be active, thus you will still not see the pv or lv in the vg. You will need to activate to use:

vgchange -a y /dev/mpatha1

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .