I would need some help with an HP DL360e to install ssd's using the b320i raid controller. I prefer using the controller over software raid, unless I really have to.

I tried the latest Debian and openSUSE leap. I want to try SUSE leap, as it would be new to me.

Anyways, I've learned that you need to pre-install the HP proprietary driver so that linux can see the raid drives. I'm a Dell guy, and I recall this being a problem with Dell R620, and I did get that going but it was on centOS.

So, here I am going into HP smart array (I think its called? F9 anyway), and I configured the RAID 1 for mirror, it picks up the drives, piece of cake.

on openSUSE boot, I can see it didn't find the drives. Ok so I go to HP support centre to pull the drivers here (I've tried both SP3 and 4 files)

I'm on a macbook, so what I did is:

  • download the compressed file 1hpvsa-1.2.16-100.sles11sp4.x86_64.dd.gz1
  • use gunzip to extract to .dd file gunzip driver/hpvsa-1.2.16-127.sles12sp4.x86_64.dd.gz
  • diskutil list to identify my USB stick
  • exec: sudo dd if=driver/hpvsa-1.2.16-127.sles12sp4.x86_64.dd of=/dev/disk2 (as instructed)
  • boot openSUSE, F6 to say I have a driver, instructions say no additional commands
  • now openSUSE asks for media to load drivers, I select the usb stick, it searches and then just asks me again for the media like it just can't find it!

I've tried different files, AMD version etc. It just will not detect the image on the stick. What am I doing wrong!? dd shows no errors when I exec image on the USB stick.

After this openSUSE will not find my RAID ssd's and cannot continue

anyone with experience on this, please help


Here is the content of my USB stick

enter image description here

  • WHat content you see when you create the USB stick? Jan 16 at 16:00
  • 1
    hello @RomeoNinov I have updated the Q with the tree of my USB stick
    – gstlouis
    Jan 16 at 16:38
  • What version of SuSE you try to install? Jan 16 at 16:42
  • 1
    You will be much better off installing a P410 controller.
    – ewwhite
    Jan 16 at 16:50
  • @RomeoNinov SUSE leap is version 15. I figure maybe its because this driver only goes to ver 12 like the documentation explains, but the fact it asks for media, I chose it, and it just keep asking for media feel more like its just not wanting to read the flash drive
    – gstlouis
    Jan 16 at 19:34

1 Answer 1


It sounds like you're running into an issue with the HP Smart Array B320i RAID controller not being recognized by the Linux distribution you're trying to install (openSUSE Leap).

Based on the troubleshooting steps you've described, it seems you've correctly downloaded and extracted the appropriate HP proprietary driver for the B320i controller and created a bootable USB drive using the dd command. However, the openSUSE installation is not recognizing the driver on the USB drive during the installation process.

There are a few things you can try to resolve this issue:

Double-check that you've selected the correct USB drive in the openSUSE installation process when prompted to load the driver.

Make sure that the driver version you're using is compatible with the version of openSUSE you're installing.

Try using a different USB drive or USB port to create the bootable driver disk.

Check if the HP Smart Array B320i RAID controller is supported by openSUSE or if there is a work around.

If none of these solutions work, you may need to consider using software RAID instead, as the HP Smart Array B320i RAID controller may not be fully compatible with openSUSE.

You can try talking to one of the community experts on the HPE communtiy for further clarification. They respond quickly. https://hpe.to/66013k1Rb

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.