We have a satellite office connected via a VPN (setup on a Juniper firewall). While most users have no trouble, some users will randomly loose the ability to access shares at the primary location.

Other VPN resources (including access to the Exchange server that is on the same physical machine as some of the shares) remain intact. Rebooting always fixes the problem. I've tried mapping the shares via IP address rather than server name and this seems to work better, but is still not reliable for all users.

The clients experiencing the issue are XP the server with the shares is Winodws 2003. Any ideas?

  • rebooting the xp clients or the juniper fw fixes the problem? is there NAT'ing? – Nick Kavadias Feb 12 '10 at 14:41
  • Rebooting the XP client fixes the issue. – David Hamilton Feb 12 '10 at 17:40

This is most likely an issue with the desktops. By default, the "keep alive" function of the Windows network drive mapper is 15 minutes. You can find more details and steps to resolve the issue here. You could try to fix this from the server end, by extending or eliminating the auto-disconnect option.

In short, on the server end, from a command prompt, try:

net config server /autodisconnect:-1

You may need to edit the registry for the desktops having this problem as well:

Value: KeepConn
Data type : REG_DWORD
Range : 1 to 65535 (sec)
Default value: 600 sec = 10 mins

Note: you can't make it an infinite number. I would recommend using 8 hours, since that's one business day; then have people reboot in the morning to start over.

Final Note: I wouldn't rule out that those desktops might also be experiencing packet drops or network lag, which would disconnect the drives if the drives couldn't connect to to the server.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy