I installed Windows 7 RC 1 from a usb flash drive using these directions. The installation went well, however when I log into the laptop I'm getting the error message:

"There is no disk in the drive. Please insert a disk into drive \Device\Harddisk3\DR3"

I've put the thumb drive back in thinking it needed to finish the installation, but that hasn't changed anything.

Any ideas?


Turns out it was the windows logon scripts used to attach to the network drives.

I went into disk management, and there were two drive letter being used although no drives were attached, meaing drive letter G: and H: were set aside to be used by removable media, although the media wasn't available.

I've seen a similar error in Win XP, but usually only when the drives are currently being used.

I hope this helps anyone who runs across the same error message.


I had the same error when launching Miranda IM on a Vista x64 System. Your answer definately helped me in tracking down the problem. It wasn't a network drive that was not ready but a drive letter that was used by my USB Card reader but did not have a card in it. After I removed the drive letter from disk management Miranda worked like a charm!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.