I just installed tfs 2010 rc basic on my win 2008 server. Everything went ok with no warnings but when Iad try to access the team web access I get this error in a yellow box on the web page

TF31002: Unable to connect to this Team Foundation Server: servername:8080/tfs. Team Foundation Server Url: servername:8080/tfs. Possible reasons for failure include: - The name, port number, or protocol for the Team Foundation Server is incorrect. - The Team Foundation Server is offline. - The password has expired or is incorrect. Technical information (for administrator): The request failed with HTTP status 404: Not Found.

EDIT: A default collection was installed by default and is called DefaultCollection. If I go to http://servername:8080/tfs/DefaultCollection/ i get a blank response (no error). The TFS admin console claims the collection is online, but if I try to edit group membership or administer security I get an error msg "Team Foundation servers unavailable" Http code 404: Not found

I tried reinstall, uninstall and reinstall but no luck and even nothing in the event log. Very frustrating. Does anybody have some advice for where I should start looking?

SECOND EDIT: The server is a 32 bit win server 2008 SP2, the Team foundation site is running on a .net 4.0 application pool classic. I had tfs2010 beta 2 installed before which also did not work because of a bug causing tfs believe the server was on a domain which it is not. The beta 2 installation was uninstalled before installing RC. The site is not bound to a specific ip address but is on port 8080 all unassigned. There is also ca 10 other websites running on this IIS setup with http headers and bound to the servers ip address

THIRD EDIT: Reinstalled, made sure site at 8080 was removed, made sure no Sharepoint, WSS but still same problem Full size alt text

FOURTH EDIT: Both application pools was set to use LOCAL SERVICE, The http://localhost:8080/tfs/web seems to work from what you can see from the screenshot. I changed the identity of the Microsoft Team Foundation Server Application Pool to use my local administrator account but still no luck. I also changed the account in the TFS admin console to use my local admin account but still the same error. It seems strange a security error would throw 404 as well. Checked the logs and no errors beside my trying to access the http://localhost:8080/tfs/ site

  • Have you changed the account for both the service and the application pool. AFAIK you shouldn't run the account as local system. I do however have the installs here so will run through tonight. Feb 22, 2010 at 15:32
  • I guess you should not run as local system for security reasons, but I just tried it in case there were any access problems
    – terjetyl
    Feb 24, 2010 at 15:51
  • Updated my answer. Even the VS Champs I have asked are a bit stumped. The only suggestion thus far had been security. Feb 25, 2010 at 23:01
  • I actually found the problem, it was UrlScan that for some reason blocked my sites, I added a response in an answer to this question
    – terjetyl
    Feb 26, 2010 at 8:45

5 Answers 5


Finally got it. I found this blog post link text

Turns out I had UrlScan installed and this blocked my tfs site

This fixed it:

you can also fix this by telling urlscan to allow dots in paths:

Modify the urlscan.ini file in C:\windows\system32\inetsrv\urlscan

set AllowDotInPath to 1 instead of 0

There are no . in my paths but I guess there is some url rewrites going on


With team foundation server 2010, the URL format has changed slightly. try http://server:8080/tfs/DefaultCollection1

This is of-course, assuming that the default collection on your TFS installation is called "DefaultCollection1"; please feel free to modify this as necessary.


The URL for WebAccess to type in the browser is


Assuming from your FOURTH edit, you are using it like this am I right? Just to make sure.

I have installed my TFS 2010 RC on a fresh Windows 7 VM installation, with all default settings. I can access the site even from a Firefox Browser on an Ubuntu box.


There is a few things to check for. Firstly ensure in IIS that site is running and if you installed on 64Bit Server, check that the application pool is not enabling 32Bit applications to run in 64Bit instance. Also ensure that you haven't explicitly mapped your TFS site to a IP address, as this can sometimes confuse TFS completely.

The fact that you un-installed and re-installed and it re-occurred point to a problem with IIS configuration in itself. If this is an upgrade did you complete remove everything before installing the RC?

Based on your edit could I suggest that you delete the site on Port 8080 completly before re-installing and ensure that all traces of it is gone unless you need it. Also ensure that you remove and uninstall WSS or SharePoint depending on which you have installed.

One more thought, which user is the application pool configured to run as. This could potentially be a security and access issue, possibly during the installation. Also see if you can retrieve the installation log and if it reveals any security failures TFS silently ignores.

I finally had a chance to install TFS 2010 RC myself on my Windows 7 machine. From what I can see the settings you describe above is correct all the way. My installation worked out of the box. I can only imagine your getting the error due to the IIS configuration on that particular machine. My only suggestion I can make at this point is to install TFS 2010 RC on another machine with no other sites, even if for testing purposes on a Virtual Machine. If it works, compare the setting between the VM and the server your testing. Also make sure you have all the updates required by TFS 2010 loaded, and if necessary remove and re-install the .Net Framework 4.0.

Also, create a brand new site and add it to an application pool. Switch the pool to use a Framewor 4.0 pool, and test if it works. If it doesn't, the problem could be with the framework, if it does, then you've eliminated a problem with IIS.

  • Thx for the suggestion, its a 32 bit server so it isn't this problem. I suspect it has something to do with the other sites running on this iis . I also installed it on my home box, a windows 7 64 bit, and there it is working ok
    – terjetyl
    Feb 19, 2010 at 9:02
  • We are using .visualstudio.com and want to be connect tfs4jira, So this is corrent for tfs setting ? https://<Accountid>.visualstudio.com:8080 Mar 9, 2016 at 13:50


Contrary to the original post, I now can say that my own installation of the TFS2010 RC basic version works flawlessly. I've done it on a Win7 machine. So, I can not tell what the solution to the question is.

  • I will give it a try, but I don't understand why installing the standard would help over installing the basic version
    – terjetyl
    Feb 23, 2010 at 12:34
  • @tt22: I now have myself installed the Basic version, and Web Access works, contrary to what I posted first. I now have edited my post.
    – Marcel
    Feb 23, 2010 at 20:27

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .