I have installed OpenVPN on my Ubuntu 22.04 server using the system package manager and generated a configuration file for the server. When I try to use that conf file to connect to the server from my home laptop, an Arch Linux machine, with $ openvpn user.ovpn. I get the following error:

2023-03-08 14:32:15 UDPv4 link local: (not bound)
2023-03-08 14:32:15 UDPv4 link remote: [AF_INET]xxx.xxx.xxx.xxx:11194
2023-03-08 14:33:15 TLS Error: TLS key negotiation failed to occur within 60 seconds (check your network connectivity)
2023-03-08 14:33:15 TLS Error: TLS handshake failed

I have checked the firewall and ensured that port 1194 UDP was open, then thinking this might be some government or ISP blocking port 1194, I tried changing the server to listen on port 11194 but I got the same error.

When running nmap from my laptop I see that the port is open and filtered:

11194/udp open|filtered unknown

There are a few posts regarding this error on this site, but none of them apply to my situation. I have checked the ports and firewalls and can't find any issues anywhere. Anyone know how I can resolve this problem or troubleshoot it further?


You must log in to answer this question.

Browse other questions tagged .