I am in the process of trying to configure SQL Server 2008 to accept remote connections. I have been through all the documentation I can find and yet when I attempt to connect through management studio I get an error stating that the server could not be found.

Interestingly I can connect through telnet to the remote server via the port that sql server is listening on. In the SQL Server logs I can see the connection attempt. So SQL Server is up and running and listening on the correct port - no firewall blocking it.

It would appear that by default SQL Server is listening on port 50314 by default but management studio attempts to connect on port 1433.Weird.

Server Management Studio = no dice.

Anyone got any ideas? Server is set to allow remote connections - TCP IP is enabled, firewall is off.



We are seeing the connection attempt when we telnet in on port 50314 in the sql server logs. When we login through management studio we see it attempting connection on port 1433. There is no sign of this connection attempt in the logs.

  • And you're sure this isn't a named instance? Also is it possible you have TCP dynamic ports set up? Have you tried using post 50314 in the connect to server box in SSMS? Here are instructions on configuring port number on the SQL Server box: msdn.microsoft.com/en-us/library/ms177440.aspx – Aaron Bertrand Feb 13 '10 at 14:06
  1. Make sure the SQL Server Browser Service is on at the remote server as this will make it easier to find it
  2. Verify that the SQL Server is running on port 1433, if not you'll need to specify , PORT# after the server name in SSMS
  3. Make sure that the SQL Server is setup to operate on TCP/IP. It may be limited to Named Pipes for example.
  4. Make sure the SQL Server is setup as the default instance MSSQLSERVER, if not you'll need to specify the SERVERNAME\INSTANCE in SSMS
  • Also, the "sa" account is disabled by default. If your connecting with mixed-mode auth and the 'sa' user , you still need to enable the user and set its password. Also, you are able to change the port that the SQL instance listens on. You can try that if their is any conflict on port 1433 for some reason. Also, make sure your windows firewall isn't blocking that port. – djangofan Apr 8 '10 at 17:55

Are you saying that in the SQL Server error log you are seeing the connection attempt by Management Studio? If so, what does the log say about why the connection couldn't be established (it might differ from what SSMS tells you, since if the log is recording the message on the server side, obviously the server could be found)? Are you using a server name, if so have you tried using the IP address instead? And are you 100% certain that SQL Server is in fact listening on port 1433? And also that it is not a named instance? For a named instance you would need to connect to [server name or IP][instance name].


We had this a couple months ago with our SQL Server 2008 box. The root cause was an issue with the domain account that was binded the SQL server service, somebody changed the password. Try this before attempting the dreaded reboot.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.