I recently upgraded a Zabbix server from version 5.x to 6.4, after doing so, a regular user (not an admin) stopped being able to access a certain dashboard on any of the hosts he have access to.

Reproduction scenario:

  1. log in to zabbix frontend
  2. search for the host name using the search bar -> will give you the search results page
  3. in the search result page, on the relevant host line, click on "Dashboards" in the "Monitoring" section
  4. result -> an empty Dashboards page saying "No data found"
  5. doing the same steps 2-4 with a privileged user (admin) gives the correct dashboard

What I already tried:

  • In the "Users" page -> "Permissions" tab: I verified that the user has read access to the host group in which this host belongs to
  • In the "Users" page -> "Permissions" tab: I verified that the user has "Dashboards" permission
  • Using the same 1-2 steps I checked that the user have access to any of the graphs that are used in the relevant dashboard.
  • I tried to add another dashboard with one graph to the same host template, couldn't see any of them from the regular user.

Any further ideas ?


You must log in to answer this question.

Browse other questions tagged .