-1

I am using an amazon linux 2023 box and i joined the instance to domain using realmd.

The issue is that when i try to login with my AD credentials, the user directory is being created as /home/username@domain instead of /home/username.

Here is my /etc/sssd/sssd.conf file:

[sssd]
domains = avengers.local
config_file_version = 2
services = nss, pam
default_domain_suffix = AVENGERS.local

[domain/avengers.local]
default_shell = /bin/bash
krb5_store_password_if_offline = True
cache_credentials = True
krb5_realm = AVENGERS.LOCAL
realmd_tags = manages-system joined-with-adcli
id_provider = ad
fallback_homedir = /home/%u@%d
ad_domain = avengers.local
ldap_id_mapping = True
access_provider = ad
ad_gpo_access_control = disabled

Can someone please help me ?

1 Answer 1

2

Change

fallback_homedir = /home/%u@%d

to

fallback_homedir = /home/%u
0

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .