I hope there is some WSUS expert around.

-Deployed WSUS settings using a gpo linked to the OU the computer is in.

-When I check the group policy it says it is correctly applied and the values in the registry match.

-When I use WSUS Client Diagnostic it shows the correct server and settings

-In WSUS Administration Console the client reports but is in error. (Because it fail to download some updates)

Now the interresting part :

-When I check the WindowsUpdate.log on the client it show it connect to http//wsusnewserver but when it's trying to download the missing updates it's attempting to get them from http//wsusoldserver and get an error that the file is missing, which is normal.

Please help. I tried the /force switch on gpo with no success, the GPO really seems to correctly apply, but it's like there is a referrence to the old server in the settings somewhere but I cant find where.


Clearing the client cache directory worked for my problem :



Is the old server still on the network and visible? Have you tried an ipconfig /flushdns

  • Yes the old server is still up and running, but I had no problem to move other clients by the GPO, only with this one. ipconfig /flushdns had no effect. I tried rebooting with no success. The client report and speak with the good server it's just when it try to download a file that he try to use the old server. – Shmoo Feb 17 '10 at 14:53
  • In the registry on the affected machine, the entry under HKLM\Software\Policies\Microsoft\Windows\WindowsUpdate has the new server listed under WUServer and WUStatusServer as well? – DanBig Feb 17 '10 at 14:56
  • Yes, as I said the GPO seems to apply correctly – Shmoo Feb 17 '10 at 15:02
  • What is the client OS, and SP level? – DanBig Feb 17 '10 at 15:05
  • WinXP SP2, we didnt deploy SP3 yet due to some instability with some of the programs we use. But in the risk of repeating myself, this Client is pretty much like all the other clients that I was able to move successfuly with the GPO. I dont know what is different with this one that makes it try to update on the old server. – Shmoo Feb 17 '10 at 15:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy