0

I upgraded apache on RHEL4 using Jason Litka's RPM repository (actually I upgraded PHP, but it updated apache for me), and now apache won't start. There are no errors on startup, it just won't start. I tracked it down to conf.d/ssl.conf and particularly the line Listen 443. Please let me know if you need more information

Edit If it helps, here's the output from strace: http://pastebin.com/f6ee7ed61

0

Is there something else listening on port 443?

1
  • No. Was my first inclination also. I checked with lsof -i:443, which turned up nothing. – blockhead Feb 17 '10 at 23:26
0

Apparently there was something it didn't like about the vhost setting.

0

hey if you do a httpd -l what modules are listed? Is the mod_ssl included in the Apache conf?

Also are you sure no errors appear in var/log/messages or elsewhere

J

0

If you pull out ssl.conf does it start? If so, maybe the mod_ssl and apache version do not the correct module magic number. You may need to update mod_ssl as well or even openssl using the alternate repo.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.