1

I am a newbie FreeBSD user and I would like to install FreeBSD 13.2 on a DELL PowerEdge R430 server hardware. After downloading and booting from a bootable USB stick made from image "FreeBSD-13.2-RELEASE-amd64-dvd1.iso", FreeBSD boot menu appears and when I press enter, tons of texts are running, I can't even stop to read it. When it stops I receive some USB bus related error messages. Is it possible to somehow overcome this issue? I tried several USB related options in BIOS but I get alwys the same result. See attached screenshots. Couldn't find any resolutions using Google.

enter image description here enter image description here

4
  • This maybe because you are using a DVD image on a USB stick. Try using FreeBSD-13.2-RELEASE-amd64-memstick.img Commented Aug 12, 2023 at 8:07
  • I've tried to use "FreeBSD-13.2-RELEASE-amd64-memstick.img" to create the bootable USB stick. I get the same USB related error messages. It seems the issue is related to some kind of USB device integrated on motherboard. I even tried to remove iDRAC module, but I get the same error messages.
    – JackD
    Commented Aug 14, 2023 at 14:27
  • How long did you wait? It looks like you're getting some timeout errors regarding mfi SCSI devices.. In general, USB errors should not be a problem unless it will end up with inaccessible boot media, but it doesn't look like you're getting to the point of mounting anything. Commented Aug 15, 2023 at 11:56
  • I've waited few minutes. It gets into some kind of loop. I'll try to identify repeating messages in loop in the next few days.
    – JackD
    Commented Aug 15, 2023 at 16:23

1 Answer 1

0

First disable USB v3.0 in BIOS, had issues with it enabled.

Then from Boot Menu select option 3: Escape to loader prompt

set hw.mfi.mrsas_enable="1"

boot

Don`t forget to edit /boot/loader.conf after installation and add

hw.mfi.mrsas_enable="1"

mrsas_load="YES"

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .