0

We have a CentOS 8 server that has recently had a lvm fill up on available space. This was not our monitoring system since it watches the disk space and not the volume space. Regardless I am having trouble extending the space on the logical volume. Currently we have sdb which I have extended from 132 to 160. I think extended the sdb3 partition to the max size putting it at 158.4. That then has two lvms under it, one at 128/128 and another at 2.4. The lvm I am trying to extend is called cl_lifprodredo-root, so I tried running the commands lvextend -r -l +100%FREE /dev/cl_lifprodredo/root and then I tried the same command with sudo and adding the -v flag as well. Both commands failed to extend the lvm. I've attached the output of the command sudo lvextend -v -r -l +100FREE /dev/cl_lifprodredo/root as well.

enter image description here

If anyone has some additional advice on how to extend the lvm it would be greatly appreciated. It is a virtual machine so I am able to add additional space as needed, especially if the extra space needed to be allocated straight to the LVM and not the partition.

1 Answer 1

0

Added additional space to the disk and reran the commands from this post.

I had previously done so as well, and then ran lvextend -r -l +100%FREE /dev... with the correct file path. Previously when looking at the output of pvs it listed no free space, not sure if I just didn't run the pvresize or where my original attempt at extending the space went wrong but it has now been resolved with the process from the linked post and the lvextend command.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .