I'm running an Ubuntu 9.10 (Karmic) system, but would like the beta Lucid repositories enabled for some packages I need bleeding-edge versions of. I'm trying to use apt-pinning so that they will never, ever use those packages unless specifically asked for. I added the following to my apt/sources.list:

deb http://archive.ubuntu.com/ubuntu lucid main restricted universe multiverse

I have the following in my apt/preferences:

Package: *
Pin: release a=lucid
Pin-Priority: 25

And in fact, if I inspect the system configuration with apt-cache, I see:

  Installed: 1:0.8.4-0ubuntu2.1
  Candidate: 1:0.8.4-0ubuntu2.1
  Version table:
     1:0.8.4-0ubuntu13 0
         25 http://archive.ubuntu.com lucid/main Packages
 *** 1:0.8.4-0ubuntu2.1 0
        100 /var/lib/dpkg/status
     1:0.8.4-0ubuntu2 0
        990 http://us.archive.ubuntu.com karmic/main Packages

Which seems perfectly right! But aptitude is quite convinced it must upgrade compiz (among others) to the Lucid versions. apt-get, puzzlingly enough, knows not to upgrade. Why are my pins not being respected?


I think you are, but just checking if you are actually using /etc/apt/preferences or files in /etc/apt/preferences.d/? It seems that aptitude ignores the files in /etc/apt/preferences.d/.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy