I have installed NFS on a server in my lab, the server exports two disks, /disk1 and /disk2, i can successfully see the exported drives using:

showmount -e

I can also mount the drives:

mount /disk1

This gives me a mounted drive on my local machine (also NetBSD 9.3) /disk1

However, I am not able to add, delete or modify files, i get:

touch: notes.txt: Permission denied

The local folder used for the mount point is owned by the user user (non-root) the mount point on the server for /disk1 and /disk2 is also owned by a user called user (non-root), same group and uid, 1000 and 100.

This is my /etc/exports file:

/data1 -alldirs -mapall=1000:100 -network -mask
/data2 -alldirs -mapall=1000:100 -network -mask

I have tried mounting as root, both locally and on the server, I have also tried the same thing as user, nothing seems to help, any help is greatly appreciated!

Update I do not know what fixed it, but everything is working now, I have tried unmounting the drives and mounting again, restarting the server etc. everything still works, same /etc/exports file, no changes, same users and rights.

  • Make sure that your exports are in read-write mode. On other systems this done typically by adding 'rw' option to the export entity.
    – kofemann
    Oct 3 at 10:29
  • In NetBSD, as with all systems using the 4.4BSD NFS implementation, the entries in /etc/exports (see exports(5)) default to read/write mode (adding the -ro option to an entry changes this). Oct 3 at 20:20
  • Note also this warning in the CAVEATS section in the mount_nfs(8) manual page, An NFS server should not mount its own exported file systems. Oct 3 at 20:23

1 Answer 1


In theory this should have worked I think, but unfortunately there are so many potential causes for EACCES that identifying the particular cause in this case is difficult given just the information you have supplied so far.

You could try taking out the -mapall option. I've never used it in any configurations I've created or managed and given your description of the filesystem permissions on the server it should not be necessary.

However please edit your question to add the output of the following commands run on both the server and the client after the mount is made, and run them as user:

ls -ld /disk1

Perhaps that information will make the problem obvious.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .