I'm running Mac OS X 10.6.

How do I force configure to compile in 32 bit mode?


You could simply set the CFLAGS and CPPFLAGS :

export CFLAGS=-m32

export CPPFLAGS=-m32

These flags will simply force gcc to use the -m32 option, which compiles into 32 bits mode.

So if you only have one file to compile, you can use:

gcc -m32 myfile.c

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.