I want to connect to windows server 2019 through WMI.

I test the connection by Paessler WMI tester and I get 80070005: Access is denied.

I did the following but the problem is not resolved.

  1. give access the user to root\cimV2 in wmimgmt.msc.

  2. user is the member of Administrators , Performance Monitor Users, Distributed COM Users

  3. user has permissions to DCOM

  4. UAC is disabled by setting LocalAccountTokenFilterPolicy in HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\System

  5. Remote client ip is added to trusted host of the server by following command in powershell:

  • get-service winrm -enable-PSRemoting -force
  • winrm s winrm/config/client '@{TrustedHosts="clientip"}'
  • winrm quickconfig
  1. Grant access to the user to connect from the network by configuring in policy:
  • Computer configuration > Windows Settings > Security Settings > Local Policies > User Rights Assignment: add user to Access this computer from the network
  1. give WMI Access to client in server's firewall
  • Most of those actions are unnecessary due to the user is an administrator. You should include results of the local WMI test.
    – Greg Askew
    Commented Dec 31, 2023 at 8:51
  • moreover it is not advised to disable the UAC for no reason. if its such a buggy application still needs it I wozld really think about it's age
    – djdomi
    Commented Dec 31, 2023 at 9:01
  • I checked event viewer and following error created when I send a new request. The server-side authentication level policy does not allow the user user_name SID (S-1-5-21-1973546343-3298082641-2350970666-1018) from address to activate DCOM server. Please raise the activation authentication level at least to RPC_C_AUTHN_LEVEL_PKT_INTEGRITY in client application. Commented Dec 31, 2023 at 11:16
  • You should consider testing this remotely by using an actual WMI command. Dropping partial information amongst what is mostly irrelevant information isn't a good approach for symptom isolation.
    – Greg Askew
    Commented Dec 31, 2023 at 14:13
  • Could be that the the user using passler and querying wmi needs to be a member of the the local administrator group. But i also see you setting psremoting,I don't understand why
    – Turdie
    Commented Jan 9 at 12:25

1 Answer 1

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .