0

I'm running a FreeNX server on headless CentOS machine, and the resolution seems to be locked on 800 x 600. I tried editing the xorg.conf file, but without success so far.

Has anyone succeed of running the FreeNX remote under 1280 x 1024 resolution, and can post a working configuration?

Thanks!

P.S.: Here is the pastebin of my current xorg.cof file: http://pastie.org/835308

1

As far as i know the display area is set clientside when the session is created.

Using the official client.

Click Configure with the session you wish to alter selected.

Under the display group, select Available Area.

Click Ok

  • Just tried - still shows 800x600. – SyRenity Feb 21 '10 at 12:02
2

The best way to use headless with your current video driver (instead of vesa) is to use "CRT-0" monitor:

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "ConnectedMonitor" "CRT-0"
    Option         "UseEDID" "FALSE"
    SubSection     "Display"
        Depth       24
        Modes      "1280x1024"
    EndSubSection
EndSection

The driver will try to determine valid modes and while it is the CRT-0, the driver will fail to obtain mode and will use the default (which is 800x600) So you need to explictly tell the driver to use "1280x1024" which is defined in the Monitor0 section as:

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Fake Vendor"
    ModelName      "Fake CRT"
    HorizSync       28.0 - 80.0
    VertRefresh     48.0 - 75.0
    ModeLine       "1280x1024" 108.88 1280 1360 1496 1712 1024 1025 1028 1060 -h sync +vsync
    Option         "DPMS"
EndSection

Restart X and voila!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.