I've tried the previously answered questions regarding this to no avail.

Just installed PHP5 and IIS on my Windows 7 machine and I'm having trouble getting PHP Errors displayed instead of 500 Errors.


error_reporting = E_ALL
display_errors = On

In IIS I have htmlErrors set to Detailed which shows a detailed IIS 500 Error page. If set to Custom it shows a basic 500 Error page.

If I set it to PassThrough I get a blank page (view-source reveals no code).

My PHP log file is showing a Fatal PHP Runtime Error.


Double click "ASP" in the sites Home screen in IIS admin, expand "Debugging Properties" and enable "Send errors to browser" and click "Apply".

Under "Error Pages" on the home screen select "500", then "Edit feature settings" and select "Detailed Errors".


Are you using the rewrite module in IIS by any chance?

I have found that the rewrite module tends to screw with the PHP errors always forcing them to ERROR500 instead of showing me the code issue.

If you are comment out the rewrite code in the web.config of the site and do your testing.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy