0

Below is a diagram of my network:

network diagram

MAIN router: 192.168.0.1 with DHCP assigning beginning at 192.168.0.5

2nd router: Running openWRT in AP mode. Receives a statically-assigned IP of 192.168.0.2 from main router

The issue for me now is this:

if I connect to the 2nd router's wifi, I get a DHCP assigned IP from the main router, since the 2nd one is acting as a DHCP client. I'll get something like 192.168.0.105

however if I connect to a LAN port on the 2nd router (or the POE switch, like the Home Assistant device is connected to), I'm getting assigned on a different subnet, like 192.168.1.200 (with the .1 instead of .0). So essentially it's acting like it's own router and not a DHCP client from main router.

With this happening the Home Assistant can't see any devices connected to the MAIN router.

I would like everything on my whole network (wired or wifi) to receive IP's on the same subnet (192.168.0.X).

In the 2nd router's OpenWRT settings, I tried assigning the 2nd router's LAN interface IP to 192.168.0.2, or even try setting the LAN interface to "DHCP client". (the WAN interface is set to DHCP client), but the configuration will fail upon save and revert.

LAN interface settings 2nd router

all interface settings 2nd router

6
  • 2
  • I did I was actually following that exact guide, but when I follow this step: Give the wireless AP an IP address “next to” your main router. It's set at 192.168.1.1 and I try to change it to "192.168.0.2". I click "save and apply", and it fails to apply and reverts back to "192.168.1.1"
    – darnitdiy
    Commented Mar 4 at 18:29
  • 1
    Essentially, you have to turn off DHCP and NAT. The OpenWRT router will become a layer-2 only device.
    – Ron Trunk
    Commented Mar 4 at 18:31
  • ... and just use a LAN port for the uplink. The WAN port would require proper configuration to disable NAT and enable bridging.
    – Zac67
    Commented Mar 4 at 20:17
  • no matter what I try I can't get this to work using LAN port for uplink: - bridge in OpenWRT to the LAN port (eth1) - my computer gets on same subnet as main router - home assistant doesn't get IP (on POE switch connected to another LAN port, d using WAN port for uplink: - bridge in OpenWRT to the WAN port (eth0) using - everything gets an IP, but on two subnets I tried following the directions exactly and I get "failed to apply configuration". It just reverts back to 192.168.1.1 for the 2nd router
    – darnitdiy
    Commented Mar 5 at 2:09

0

You must log in to answer this question.

Browse other questions tagged .