0

I am doing a very basic setup with a MikroTik router: an ISP modem in bridge (dumb modem) mode, a static public IP, router with DHCP server enabled, LAN. I have followed manufacturer's "Getting started" manual (https://help.mikrotik.com/docs/display/ROS/First+Time+Configuration) as well as read DHCP server section of the manual. Everything seems to work OK, but I get this minor annoying thing: a LAN DHCP client gets two gateway addresses from the DHCP server - one private IP address of the router (which is what I want) and also, annoyingly, a public IP static address of the ISP, which I don't want:

   ipconfig /all
   ...
   Physical Address. . . . . . . . . : XX-XX-XX-XX-XX-XX
   DHCP Enabled. . . . . . . . . . . : Yes
   Autoconfiguration Enabled . . . . : Yes
   IPv4 Address. . . . . . . . . . . : 192.168.0.100(Preferred) 
   Subnet Mask . . . . . . . . . . . : 255.255.255.0
   Default Gateway . . . . . . . . . : 1.2.3.4
                                       192.168.0.0
   DHCP Server . . . . . . . . . . . : 192.168.0.0
   DNS Servers . . . . . . . . . . . : 192.168.0.0
   NetBIOS over Tcpip. . . . . . . . : Enabled

Here 1.2.3.4 is a substitute for an actual public static IP address of my ISP's gateway that I do not want to be delivered to DHCP clients.

Notably, if I do static configuration of the LAN clients instead of DHCP by specifying only one default gateway (192.168.0.0), everything still works, so no, ISP's default gateway address is not required for proper functioning of the LAN clients.

What am I missing in MikroTik router configuration (Router OS version 7.13.5) in order for the router not to expose ISP's default gateway address to the DHCP clients on the LAN?

1 Answer 1

1

I found the reason and it has nothing to do with the router. The reason is that Windows IPv4 configuration for the network adapter, although having been switched to DHCP mode, retained an ISP's default gateway address as a static setting from my prior attempts to connect a single LAN client directly to the ISP bridge modem.

Apparently, when you switch from static to dynamic config in Windows 10 (maybe in other versions too), the operating system properly forgets the old static IP address, subnet mask and DNS servers and issues a DHCP request, but somehow remembers the old default gateway address and adds its value to the new default gateway address received from DHCP. You can confirm that if you go back to the adapter IPv4 settings and click on "Use the following IP settings" radio button instead of "Obtain an IP address automatically", you will see that the IP address and subnet mask will be properly blank, but default gateway address will be pre-populated with your old value.

You can't just erase this value and press OK, as Windows will complain that you did not populate the IP address and subnet mask, and you can't also erase the value and then click away back to the "Obtain an IP address automatically" option, as Windows will then ignore your changes you have made in the static config section. What you need to do to fix the problem is to temporarily configure the LAN client back into static mode with the default gateway address of your router and then switch back to DHCP configuration. Apparently once Windows sees a match between old static default gateway address and the new one received from DHCP, it will properly erase a static value instead of growing a list of default gateways.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .