I have a dell poweredge 2970 server with a serial console over ip enabled on the first ethernet.

The server with Red Hat enteprise 5.4 is configured to have console over ttyS1 in grub (console=ttyS1,57600 ) and in /etc/inttab I have:

S1:2345:respawn:/sbin/agetty -L -h ttyS1 57600 vt100

I can connect to console from another server using :

ipmitool -I lanplus -H myipmiIPaddress -U root -P password sol activate

but in the server I have /var/log/messages flooded with init: Id "S1" respawning too fast: disabled for 5 minutes.

If I remove the entry in inttab I can't connect anymore so I suppose it's not completely wrong, how could I avoid it respawing?

  • What happens when you run, /sbin/agetty -L -h ttyS1 57600 vt100 directly ? Does /dev/ttyS1 exist ? – Dave Cheney Feb 23 '10 at 12:56
  • /dev/ttyS1 exists if I launch it by hand (after disabling it from inittab) at the moment I have no output and console doesn't work – golemwashere Feb 23 '10 at 14:38
  • sol info: Info: SOL parameter 'Payload Channel (7)' not supported - defaulting to 0x0e Set in progress : set-complete Enabled : true Force Encryption : true Force Authentication : false Privilege Level : ADMINISTRATOR Character Accumulate Level (ms) : 50 Character Send Threshold : 220 Retry Count : 7 Retry Interval (ms) : 1000 Volatile Bit Rate (kbps) : 57.6 Non-Volatile Bit Rate (kbps) : 57.6 Payload Channel : 14 (0x0e) Payload Port : 623 – golemwashere Feb 23 '10 at 15:08

securetty must not have the 'dev' part.Add just ttyS1. Also if the com port is shared between the system and bmc, change the mux setting to BMC from system. There is an ipmi command to switch port between system and bmc. (you can also do via Dell racadm)

  • securetty doesn't have the dev part. I tried to instal racadm but it hangs on: racadm -r ip -u root -p password getconfig -g cfgSerial The BIOS was set for console on com1, do you have the syntax for ipmitool commad to switch port? see my above comment for ipmi sol info (quite cryptic) – golemwashere Feb 24 '10 at 11:55

I have seen agetty respawning during sol, but it wont occur so often. Makesure you have added securetty entry and check whether if any firewall/selinux is preventing agetty.

  • I have selinux disabled and /etc/securetty contains /dev/ttyS1, iptable is disabled – golemwashere Feb 23 '10 at 14:39

cfgSerial is for serial interface, also you have enable the user to access sol check cfgUserAdminSolEnable

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.