0

Running Ubuntu 22, it still allows me to log in via SSH as root-user.

I run the following configuration in /etc/ssh/sshd_config:

PasswordAuthentication no
PermitEmptyPasswords no
PubkeyAuthentication yes
PermitRootLogin no

Full content:

Include /etc/ssh/sshd_config.d/*.conf

#Port 22
#AddressFamily any
#ListenAddress 0.0.0.0
#ListenAddress ::

#HostKey /etc/ssh/ssh_host_rsa_key
#HostKey /etc/ssh/ssh_host_ecdsa_key
#HostKey /etc/ssh/ssh_host_ed25519_key

# Ciphers and keying
#RekeyLimit default none

# Logging
#SyslogFacility AUTH
#LogLevel INFO

# Authentication:

#LoginGraceTime 2m
PermitRootLogin without-password
#StrictModes yes
#MaxAuthTries 6
#MaxSessions 10

#PubkeyAuthentication yes

# Expect .ssh/authorized_keys2 to be disregarded by default in future.
#AuthorizedKeysFile .ssh/authorized_keys .ssh/authorized_keys2

#AuthorizedPrincipalsFile none

#AuthorizedKeysCommand none
#AuthorizedKeysCommandUser nobody

# For this to work you will also need host keys in /etc/ssh/ssh_known_hosts
#HostbasedAuthentication no
# Change to yes if you don't trust ~/.ssh/known_hosts for
# HostbasedAuthentication
#IgnoreUserKnownHosts no
# Don't read the user's ~/.rhosts and ~/.shosts files
#IgnoreRhosts yes

# To disable tunneled clear text passwords, change to no here!
PasswordAuthentication no
PermitEmptyPasswords no
PubkeyAuthentication yes
PermitRootLogin no

# Change to yes to enable challenge-response passwords (beware issues with
# some PAM modules and threads)
KbdInteractiveAuthentication no

# Kerberos options
#KerberosAuthentication no
#KerberosOrLocalPasswd yes
#KerberosTicketCleanup yes
#KerberosGetAFSToken no

# GSSAPI options
#GSSAPIAuthentication no
#GSSAPICleanupCredentials yes
#GSSAPIStrictAcceptorCheck yes
#GSSAPIKeyExchange no

# Set this to 'yes' to enable PAM authentication, account processing,
# and session processing. If this is enabled, PAM authentication will
# be allowed through the KbdInteractiveAuthentication and
# PasswordAuthentication.  Depending on your PAM configuration,
# PAM authentication via KbdInteractiveAuthentication may bypass
# the setting of "PermitRootLogin without-password".
# If you just want the PAM account and session checks to run without
# PAM authentication, then enable this but set PasswordAuthentication
# and KbdInteractiveAuthentication to 'no'.
UsePAM yes

#AllowAgentForwarding yes
#AllowTcpForwarding yes
#GatewayPorts no
X11Forwarding yes
#X11DisplayOffset 10
#X11UseLocalhost yes
#PermitTTY yes
PrintMotd no
#PrintLastLog yes
#TCPKeepAlive yes
#PermitUserEnvironment no
#Compression delayed
#ClientAliveInterval 0
#ClientAliveCountMax 3
#UseDNS no
#PidFile /run/sshd.pid
#MaxStartups 10:30:100
#PermitTunnel no
#ChrootDirectory none
#VersionAddendum none

# no default banner path
#Banner none

# Allow client to pass locale environment variables
AcceptEnv LANG LC_*

# override default of no subsystems
Subsystem   sftp    /usr/lib/openssh/sftp-server

# Example of overriding settings on a per-user basis
#Match User anoncvs
#   X11Forwarding no
#   AllowTcpForwarding no
#   PermitTTY no
#   ForceCommand cvs server

Running the command

strings $(which sshd) | grep -i "sshd_config"

shows the correct path for the config file:

/etc/ssh/sshd_config

Command:

ls -l /etc/ssh/sshd_config.d/*.conf

ls: cannot access '/etc/ssh/sshd_config.d/*.conf': No such file or directory

> sshd -T


port 22
addressfamily any
listenaddress [::]:22
listenaddress 0.0.0.0:22
usepam yes
logingracetime 120
x11displayoffset 10
maxauthtries 6
maxsessions 10
clientaliveinterval 0
clientalivecountmax 3
streamlocalbindmask 0177
permitrootlogin without-password
ignorerhosts yes
ignoreuserknownhosts no
hostbasedauthentication no
hostbasedusesnamefrompacketonly no
pubkeyauthentication yes
kerberosauthentication no
kerberosorlocalpasswd yes
kerberosticketcleanup yes
gssapiauthentication no
gssapicleanupcredentials yes

This shows:

permitrootlogin without-password

Also, I figured out, that as a normal user, I can't login via "su" as root. But from outside I can signin via SSH.

I have restarted the sshd-service several times and even rebootet the server.

The directory

I want to achieve that no root can login anymore, only dedicated users via SSH. How to achieve that?

5
  • 1
    The way you showed us the config doesn't prove there is no overriding rules below these. Show the complete config file. Also, what is in /etc/ssh/sshd_config.d (or whatever other files included in the config)? Apr 19 at 16:46
  • 2
    Also use sshd -T to dump the actual configuration that sshd is using and if it's not clear what's gone wrong from that, post the result.
    – tsc_chazz
    Apr 19 at 16:47
  • I dumped the full file and added more information. Thanks for requesting this information @NikitaKipriyanov
    – itinance
    Apr 19 at 17:40
  • 2
    permitrootlogin without-password allows direct root authentication with a public key, but not with a password Apr 19 at 17:49
  • @NikitaKipriyanov but i tried to overwrite this in my sshd_config which seems to not work
    – itinance
    Apr 19 at 18:16

1 Answer 1

5

Because, according to the sshd_config man page:

Unless noted otherwise, for each keyword, the first obtained value will be used.

And in your config file, PermitRootLogin without-password comes before PermitRootLogin no. The safest course of action is to comment out all other instances pf PermitRootLogin before trying to set it.

1
  • ouch.... Thanks a lot! i haven't seen this. Neither me nor VIM nor Strg-F :D
    – itinance
    Apr 19 at 19:58

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .