1

I have a Dell PowerEdge R530 server, which I've had for at least a few years now. All of a sudden a few days ago, the fans got really loud, as if it were rebooting, then after some time would quiet down. Everything was still running, no reboots happened, and the load was no higher or peakier than usual.

What I found is that the blue light at the back, which normally is solid, was blinking, as well as the little button with an italicized i on the front blinking blue. The little screen read "Unrecognized Post Code" sometimes, and the service tag other times.

I tried rebooting, and got two errors: UEFI0315 (Unable to process an iDRAC request to configure Secure Boot keys because of a communication error between BIOS and iDRAC.), and UEFI0029 (Unable to initialize iDRAC because of some critical issues.). I unplugged the server for a few minutes, powered it back on, and it booted fine. However, I still have the strange fan behavior (it seems to be more consistently loud instead of on and off), and the little button/screen seems to be cycling through a few states: completely off, on and showing the service tag with no blinking lights, blinking lights, then "Unrecognized Post Code" on the screen. Then it goes blank, the button lights up solid blue, the blue light in the back turns off, and it returns to a black screen and no lights illuminated. It almost seems like the iDRAC or whatever controls the screen is in some sort of bootloop, with the server itself being fine.

I rebooted to poke around on the F2 menu. The BIOS version is 2.13.0. The iDRAC version is 2.83.83, and the log it has doesn't show anything relevant (only thing I could find going back months was just routine stuff like the chassis being opened/closed or PSUs being unplugged). I did try to exit and go back, and it said the iDRAC wasn't on that time, which maybe supports the hypothesis that the iDRAC is shutting off and coming back on in a loop (also maybe explaining why the fan noise was some of the time, not all of the time).

Does anyone know what this might be, or how I could fix it? Should I try updating my UEFI or iDRAC firmware? Is there a good next step I could take to investigate the cause of the issue? Thanks!

Update: I've since swapped in a brand new motherboard, took the BIOS and iDRAC firmware through 8 years of updates to the newest versions, and as soon as I switched to UEFI and booted into the volume with the OS on it, the issue came back. I'm at a loss.

1

1 Answer 1

2

We had the same issue, resetting the iDRAC solved it for us. Here is a list of things to check:

Surely you've already done some of these, but check all hardware components are securely connected, including memory modules, power supplies, and any additional hardware components. The blinking blue light simply means that something ain't right.

Re-seat the iDRAC module if it's removable.

Resetting the iDRAC can sometimes resolve communication issues.

You can reset the iDRAC via the iDRAC settings in the BIOS or via SSH if you can access the iDRAC interface:

racadm racreset hard

If that din't work, then continues with these steps:

Power off the server. Disconnect all power cables. Press and hold the power button for 30 seconds to drain residual power. Reconnect the power cables and power the server back on.

Have you cleared the System Event Log (SEL)? Sometimes, a full SEL can cause issues. Clear the SEL via the BIOS or iDRAC interface.

Still failing? Then continue with these:

Update Firmware: Even though you've updated the BIOS and iDRAC firmware, ensure that all firmware components, including the Lifecycle Controller and RAID controller, are up-to-date. Download the latest updates from Dell's support site and apply them methodically.

Ensure that the server is not overheating. Clean any dust from the fans and airways. Note: Faulty temperature or fan speed sensors can cause erratic fan behavior.

Verify UEFI/BIOS Settings: Double-check all UEFI/BIOS settings related to iDRAC and secure boot configurations to ensure they are set correctly. Consider resetting BIOS settings to default and reconfiguring them.

Replace iDRAC Hardware (if possible): If the issue persists, consider replacing the iDRAC module if it is a separate component. (new, it sells for around $90)

Check iDRAC Logs: Access the iDRAC web interface and navigate to the Logs section to check for any critical errors or warnings.

Dell Diagnostics: Run Dell’s built-in diagnostics tool from the BIOS or via the Lifecycle Controller to identify any hardware issues.

Test with Minimal Configuration: Remove non-essential components (extra memory modules, PCI cards, etc.) and test the server with minimal configuration to see if the issue persists.

Review Firmware Compatibility: Make sure there are no compatibility issues between the firmware versions of different components (iDRAC, BIOS, RAID controller, and so on.).

Network Configuration: Verify that network settings for iDRAC are correctly configured and there are no network-related issues causing the iDRAC to behave erratically.

In theory, the solution is found in this document: https://dl.dell.com/topicspdf/poweredge-r530_owners-manual_en-us.pdf

Good luck!

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .