I'm trying to install SQL Server 2008 on an XP machine alongside SQL Server 2005, however during the instalaltion process the user that the SQL server browser is to be installed under is listed as "Domain\Machinename" - I'm unable to change that "user" and the installation fails with the message "invalid user "Domain\Machinename"".

The installation does technically finish, and the client components are installed, but I cant see the new SQL server instance services in administrative tools and I cannot connect to my new instance.

I've already tried uninstalling and re-installing SQL Server 2008 with no joy - does anyone have any ideas on how to fix with (preferably without removing SQL server 2005)


It kinda sounds like you're trying to install SQL 2008 as the default instance when the default instance already belongs to your SQL 2005 install (there can be only one default instance). If this is true then you'll have to do one of the following

  1. Upgrade your SQL 2005 default instance to 2008
  2. Install a named instance of SQL 2005, remove the default instance, then install SQL 2008 as the default instance
  3. Install SQL 2008 as a named instance, keeping your SQL 2005 instance(s) intact
  • I'm trying to install a named instance "sql2008"
    – Justin
    Feb 24 '10 at 9:02

The problem was that the existing SQL2005 installation had the SQL server browser service installed with the incorrect user given (the service was disabled, but I was using the default SQL2005 instance, so I didn't notice).

The SQL 2008 installation was apparently taking the existing service details as paramters for installing the new service - fixing up the existing installed SQL server browser serivce meant that I could install correctly.


Detach or backup your SQL 2005 databases. Unistall SQL 2005. Install SQL 2008, and attach or restore your SQL '05 databases to the new instance. Like squillman said, you're probably fighting with the named instance problem of having two SQL servers trying to run.

Good luck, and hope this helps some.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.