I have MS Access 2003 application connected to SQL Server 2005 with linked tables. Starting from yesterday when I open a linked tabled and leave it open for a while (5~10 minutes) then the database gets disconnected showing following error message. What can be wrong?

INFO: I did not change any configuration for ODBC timeout and my Database admin says that he did not change anything on the server either.

What should I check?

[Microsoft][ODBC SQL Server Driver][TCP/IP Sockets]ConnectionRead(recv()). (#10054) [Microsoft][ODBC SQL Server Driver][TCP/IP Sockets] Genral network error. Check your network documentation. (#11)


  • looks like some kind of timeout threshold is being exceeded on the server and you're being silently disconnected...just a wild shot in the dark. – Avery Payne Feb 24 '10 at 2:21

Are you running the SQL Server on Windows Server 2003? This error 10054, means that the client connection reset the connection.

To work around this problem, disable the TCP Chimney Offload feature. To do this, follow these steps:

  • Click Start, click Run, type cmd, and then press ENTER.
  • At the command prompt, type the following command, and then press ENTER:

    Netsh int ip set chimney DISABLED

More information can be found here: http://support.microsoft.com/kb/942861/en-us

  • Do I have to it on my local computer or on the server? – THEn Feb 24 '10 at 18:08
  • This would be set on the server. – Brian Knight Feb 24 '10 at 18:17

I know this question has been answered, but having spent weeks pulling out my hair with similar intermittent ODBC connection errors with Access apps, I thought I'd add something here.

One thing to check is DNS configuration on the workstations. In my case, it turned out the workstations were configured to use the Internet provider's DNS, which meant that when the workstation tried to look up the SQL Server by name, it didn't find it, since the Internet provider didn't have a DNS entry for my client's SQL Server. When the workstations were changed to use the domain controller (this was a single-server small office with SBS) as primary DNS, everything worked smoothly from then on.

I could never figure out why the problem was intermittent, though (NETBIOS over TCP/IP was disabled so it couldn't have been broadcast resolution).


Check for third party apps that grab control of TCP/IP like anti-virus or "internet access managers"/traffic shapers. I had the same problem with a traffic shaping app (XFastLan/cFosSpeed) - it would kill the ODBC connection with the OP's error msg after about 15 seconds. Uninstalling the app fixed the problem.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.