3

When I try logging into a Windows Server via Remote Desktop (RDP), I get prompted by the regular certificate warning. But then when I go and connect, it immediately gets Disconnected and I get the following Error Message "No License Server was Available".

enter image description here

1
  • 1
    I’m voting to close this question because Domain Controllers should not have Remote Desktop Service installed
    – Greg Askew
    Commented Jun 15 at 9:48

1 Answer 1

1

The quick and dirty to bypass this if you have access via a HyperVisor console was to run the following 2 commands in a PowerShell or CMD window on the Domain Controller. This allows the normal 2 concurrent user RDP sessions to the Server.

dism /ONLINE /Disable-feature /FeatureName:Remote-Desktop-Services
dism /ONLINE /Disable-feature /FeatureName:Licensing

If you do not have access to any Admin Session you can get access via a local computer with the following commands

mstsc /v:<Server>[:<Port>] /admin

The solution is documented in Depth in the Microsoft Article

https://learn.microsoft.com/en-us/troubleshoot/azure/virtual-machines/windows/troubleshoot-rdp-no-license-server

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .