I am running Windows 7 Ultimate. If I open up IIS Manager, I see a list of "connections" on the left hand side. In previous versions, I would be able to select an option to "connect to another server" or "connect to another machine", but there is no such option visible anywhere here. The only thing in the list is my local machine.

Even in the address bar, if I manually type in the server location (\servername, even tried just servername), nothing happens (it just reverts back to my current local computer)

The documentation at http://technet.microsoft.com/en-us/library/cc732466%28WS.10%29.aspx seems to imply the very same steps... but there is just no button or menu option anywhere to do this. Am I missing something? I'm not even seeing a grayed out menu option.

EDIT: Under the "File" menu, I see 2 options:

  • Save Connections (grayed out)
  • Exit

alt text

Under the "Connections" pane, I see 1 button, grayed out. When I hover the mouse, it simply says "Up", appears to be usable if I browse into an element in my local computers IIS settings

If I right click inside the pane itself, I see

  • Refresh
  • Add website (to the current host)
  • Start
  • Stop
  • Rename
  • Switch to Content View

alt text

UPDATE: I downloaded and installed the Remote Server Administration tools from http://www.microsoft.com/downloads/details.aspx?FamilyID=7D2F6AD7-656B-4313-A005-4E344E43997D&displaylang=en, and I enabled everything listed under "Remote Server Administration Tools" under "Turn Windows Features On or Off". Still nothing.

  • @Matt - I have the same problem. I've taken the liberty to add pics; hope that's OK. Win 7 Enterprise, 32-bit, UAC turned off.
    – p.campbell
    Commented Feb 24, 2010 at 21:05
  • @pcampbell Thanks!! I actually tried doing screen shots, but alt-printscreen would result in the menus going away before the screen shot, and I didn't have any software handy to do the trick.
    – Matt
    Commented Feb 24, 2010 at 21:15
  • @pcampbell Check my answer below ... found the problem
    – Matt
    Commented Feb 24, 2010 at 22:08
  • 1
    Course, now I get access denied errors (401) when trying to connect, even though I have "enabled remote connections" with "windows credentials only"... but I suppose that's another issue
    – Matt
    Commented Feb 24, 2010 at 22:18

8 Answers 8


Turns out I needed to install "IIS Manager for Remote Administration", which is discussed (and available for download) at http://www.iis.net/expand/IISManager. Why this is not part of the Windows 7 "Remote Administration Tools" I'm not sure. But after installing this I get the additional "connect" options.

  • I didn't see your answer before I posted mine. Good for you that you found the solution.
    – Luke99
    Commented Feb 24, 2010 at 22:55
  • I already have IIS Manager for Remote Administration installed, yet I am experiencing this same problem when, just days ago, I was not. I did however, attempt to reinstall IIS for RA again but now it's telling me that it isn't compatible with my system (I can't remember the exact message, but whatevs)
    – delete me
    Commented Apr 7, 2016 at 11:18
  • The link in the answer no longer works. I found this link through google microsoft.com/en-us/download/details.aspx?id=41177 After installing that and restarting my computer I get the "Connect to a Server..." option. Commented Jan 13, 2023 at 8:53

In Windows 8 (or Windows 7), you can use the Web Platform Installer to install the IIS Manager for Remote Administration. It's under 2MB.

enter image description here

The latest version should be available.

enter image description here


01/01/2018: Was unable to install IIS Manager for Remote Administration v1.2 via the Web Platform Installer (Web PI). Web PI consistently failed suggesting the file it downloaded may have been tampered with.

Instead I had to wade through this site to download and install it: https://www.microsoft.com/en-us/download/details.aspx?id=41177

  • Have this problem except the link you provided it is also now returning a 404. So there is currently no source that I can find to download this damn file!
    – hvaughan3
    Commented Sep 5, 2020 at 21:54

In the IIS Manager, try going to File->Connect to a Server. You're saying that's not there?

  • That is correct. Under File I see 2 options, 1) A grayed out "save connections", and exit.
    – Matt
    Commented Feb 24, 2010 at 20:25

Have you tried running IIS Manager as Administrator? You need to be at an administrator to remotely connect to a server via IIS Manager.

  • As soon as you said that, I thought "that must be the problem". Alas, no luck. Interestingly, when I click "run as administrator", it doesn't prompt me, like other programs when I try to run as admin. I thought it must've been kicking off from something resident in memory from previous launches, so I rebooted completely, and it still didn't ask me to approve the app running as admin.
    – Matt
    Commented Feb 24, 2010 at 20:46
  • Check this link out - it'll help you enable your tools for remote admin via IIS Manager. learn.iis.net/page.aspx/159/… Commented Feb 24, 2010 at 20:55
  • The first half of that is for the target machine... when it finally discusses how to initiate the connection it says "In IIS Manager, click File and then click Connect to a Site (or Connect to an Application). " which is exactly what is missing for me. Their screen shot looks different (has more buttons) than I see.
    – Matt
    Commented Feb 24, 2010 at 22:01

Have you tried looking for the IIS remote administration tools - that's what I had to get used to when managing 2008 boxes remotely.

  • 1
    isn't that what IIS Manager is?
    – Matt
    Commented Feb 24, 2010 at 20:55
  • Not sure cos it's been a while since I looked at 2008 - these any good? - microsoft.com/downloads/…
    – Jon
    Commented Feb 24, 2010 at 20:59
  • Gave it a shot (updated question) - no luck. Even turned on every feature inside "Turn Windows Features on or off -> Remote Admin Tools"
    – Matt
    Commented Feb 24, 2010 at 21:59

I had to install the IIS remote administration tool (as stated by Matt, and suggested by several others). However, after the install, I ran into the same problem that Matt listed: when I tried to connect to the sites, I kept getting a 401 error message.

I did a complete reboot of the system; when I logged back into the system and then tried IIS remote administration tool again, this time I was able to connect to the external site. Not sure if the reboot solved the problem or if it was something else, but hopefully this will help someone else facing the same issue.


Just thought I'd let people know my experience. I already had "IIS Manager for Remote Administration" however, I was also stuck with the OPs screenshots. No way to connect or add new connections etc.

My issue was that I guess something went a little "off" with my upgrade to Windows 10. I ran the "repair" option and this solved my issue.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .