As a developer, I had our systems team setup a VM of a server to practice an upgrade of an old third party application. This server has its own instance of SQL Server 2000 that's used exclusively for this application.

When I started up SQL Server Enterprise Manager, I was unable to connect to the local server. The error read:

An error 3 - (The system cannot find the path specified)
occurred while performing this service operation 
on the MSSQLServer service.

At first, I thought the new name and IP address of the server required to put the VM on the network might be contributing. However, I looked at the service, and it had not started. Trying to start it manually gives the same error.

I tried putting the executable path of the service into the address bar of Windows Explorer


but got the error:

Cannot find 'file:///C:/PROGRA~1/MI6841~1/MSSQL/binn/'.
Make sure the path or Internet address is correct.

When I do the same thing on the physical server (paste the path into Windows Explorer) it opens the folder just fine.

For some reason, the VM seems to be having problems recognizing the DOS compatible paths.

Any ideas on how to resolve this?

EDIT: The file and path do exist and the full path is:

C:\Program Files\Microsoft SQL Server\MSSQL\Binn\sqlservr.exe

SQL Server is not running, because this is the service that is trying to start. You get the same error if you manually try to start the service.

  • How was the VM set up? What Guest Operating system? How was SQL installed? The File:// response is weird - I can only get that if I use either an old version of IE or a non MS browser to look for a file that doesn't exist. If you just navigate to the non 8.3 location C:\Program files\Microsoft\MSSQL is there anything there? If you find the right location then try pointing the service at the path using the long file name not the 8.3 form. – Helvick Feb 25 '10 at 22:24
  • Is SQL Server running? try & start the service from services.msc what path does the SQL Server service point to? is that exe there? – Nick Kavadias Feb 26 '10 at 9:39
  • To second Helvick's comment, you might try "cd /d %ProgramFiles% & dir /x" -- that will show you the current 8.3 names in that directory. The fact that it's "MI6841~1" is a bit…wow. Unless the LFN (long filename) version of the directory contains "6841", I'd say that's a pretty strange path. – fission Feb 27 '10 at 9:11
  • I'm not sure about how the VM is setup. The VM is an image of an old system used for just one and application and has a SQL Server installed on the same box as the application. The file is there (just amended my original post). It is found on the physical box by using the DOS path, but not found on the VM (although it exists on the VM). I can edit the registry so the SQL Server service points to the long file name path, but still don't know why the VM has problems with the 8.3 path. – Feckmore Mar 1 '10 at 17:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.