3

Due to Samba needing to be at least v3.3 to have Windows 7 clients (see) we need to upgrade our version of Samba running on Ubuntu 8.10 (Intrepid). We are after a proven working package of Samba and can't find on in the normal places - Apt, backports, google etc - we really don't want to compile our own!

Is there a proven package of Samba (3.3 or better) available for Ubuntu 8.10 or are we forced to upgrade to Ubuntu 9.10 - not a light undertaking.

2

You might want to look into Apt pinning: https://help.ubuntu.com/community/PinningHowto

Summarizing, you pin your system to 8.10 but allow it to install a certain package(s) from the newer release.

Add the following (creating files as required)

To /etc/apt/apt.conf.d/01ubuntu:

APT::Default-Release "intrepid";

To /etc/apt/sources.list:

deb http://your.favourite.mirror.net/ubuntu karmic main restricted universe

And then to /etc/apt/preferences:

Package: samba
Pin: release a=intrepid
Pin-Priority: -10

Package: samba
Pin: release a=karmic
Pin-Priority: 900

You may need to fiddle with this a little and install the jaunty version of samba first (especially as you're going across two releases here). You may also find that installing samba you're asked to install a lot of updated dependencies in which case you might have to consider rolling the box up. Most packages allow a range of versions and usually going forward one release is okay. All bets are off when you go further forward however.

You'll also need to be aware of the presence of this pin before you next do a complete upgrade of the box (removing or modifying it as apporpriate).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.