7

When I run

sshpass -p 'mypass' sshfs 'root'@'68.19.40.16':/ '/dir' -o StrictHostKeyChecking=no,debug

It successfully mounts but it runs on foreground.

When I run without 'debug' parameter, it doesn't mount at all.

Server is ubuntu 8.04

Any ideas why?

UPDATE: When I run the command as ROOT it does mount. It doesn't work with other users.

here is the output of an unsuccessful mount

$ sshpass -p 'pass' sshfs  'root'@'68.1.1.1':/ '/s6' -o StrictHostKeyChecking=no,sshfs_debug,loglevel=debug
debug1: Reading configuration data /etc/ssh/ssh_config
debug1: Applying options for *
debug1: Connecting to 68.1.1.1 [68.1.1.1] port 22.
debug1: Connection established.
debug1: identity file /var/www/vhosts/devrim.kodingen.com/.ssh/id_rsa type -1
debug1: identity file /var/www/vhosts/devrim.kodingen.com/.ssh/id_dsa type -1
debug1: Remote protocol version 2.0, remote software version OpenSSH_5.1p1 Debian-5
debug1: match: OpenSSH_5.1p1 Debian-5 pat OpenSSH*
debug1: Enabling compatibility mode for protocol 2.0
debug1: Local version string SSH-2.0-OpenSSH_4.7p1 Debian-8ubuntu1.2
debug1: SSH2_MSG_KEXINIT sent
debug1: SSH2_MSG_KEXINIT received
debug1: kex: server->client aes128-cbc hmac-md5 none
debug1: kex: client->server aes128-cbc hmac-md5 none
debug1: SSH2_MSG_KEX_DH_GEX_REQUEST(1024<1024<8192) sent
debug1: expecting SSH2_MSG_KEX_DH_GEX_GROUP
debug1: SSH2_MSG_KEX_DH_GEX_INIT sent
debug1: expecting SSH2_MSG_KEX_DH_GEX_REPLY
Warning: Permanently added '68.1.1.1' (RSA) to the list of known hosts.
debug1: ssh_rsa_verify: signature correct
debug1: SSH2_MSG_NEWKEYS sent
debug1: expecting SSH2_MSG_NEWKEYS
debug1: SSH2_MSG_NEWKEYS received
debug1: SSH2_MSG_SERVICE_REQUEST sent
debug1: SSH2_MSG_SERVICE_ACCEPT received
debug1: Authentications that can continue: publickey,password
debug1: Next authentication method: publickey
debug1: Trying private key: /var/www/vhosts/devrim.kodingen.com/.ssh/id_rsa
debug1: Trying private key: /var/www/vhosts/devrim.kodingen.com/.ssh/id_dsa
debug1: Next authentication method: password
debug1: Authentication succeeded (password).
debug1: channel 0: new [client-session]
debug1: Entering interactive session.
debug1: Sending environment.
debug1: Sending env LANG = en_GB.UTF-8
debug1: Sending subsystem: sftp
Server version: 3
debug1: channel 0: free: client-session, nchannels 1
debug1: fd 0 clearing O_NONBLOCK
debug1: Killed by signal 1.
5

I've found the same problem: when combining sshfs with sshpass, it only works if sshfs is running in foreground (either with -f or -d). If it's executed in background, it executes normally with exit value 0, but it won't mount anything.

The workaround I've found is executing sshfs in foreground mode, but sending it to background with the shell:

sshpass -f passwordfile sshfs -f origin destination &

This way it will work. Then, when you don't need the mount anymore and unmount it with fusermount -u, the sshfs process will end normally.

1
  • 1
    Works, thanks! I just substituted the background task's "&" with running the process sshfs -f origin destination in the foreground inside a screen session, so I can input the ssh password manually before sending the execution/session in the background. – mab Oct 10 '18 at 9:53
0

You need access to the fuse device and that seems to be require root access.

2
  • 2
    Or being in the fuse group, unless your distro messed up that. – user1686 Mar 1 '10 at 13:53
  • my user is in fuse group - uid=10816(devrim) gid=2523(psacln) groups=2523(psacln),107(fuse) - still no luck :S – Devrim Mar 1 '10 at 22:52
0

we couldn't find a solution to this. we are running it on foreground.

0

My problem was similar and it had to do with the fuse configuration file in /etc/fuse.conf. I had to uncomment user_allow_other and the mount it without sudo: sshfs -o allow_other qube@xxx.xxx.xxx.xxx:/foo/bar /home/uesr/foor/bar/baz

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.