5

I have the Citrix ICA/receiver client installed on on both my windows an Linux workstations. On my Windows workstation I can use common keyboard shortcuts like CTRL-A, CTRL-C, CTRL-Z etc. On the Linux workstation no CTRL shortcuts work, but ALT shortcuts for menus do. How do I get CTRL to work in the Linux receiver?

5

OK, this is solved. It turns out to be an issue with the Gnome mouse settings (System->Preferences->Mouse). If you have selected "Show position of pointer when the Control key is pressed" then it won't pass Ctrl key presses to Citrix. This doesn't affect any of my other applications, including RDP clients, so I'm not sure why this is an issue for Citrix

  • Thanks for the info! I've been pulling my hair out trying to do the simplest tasks on my servers at work, now I'm back in business.I've run into issues with "show the pointer" before and now I recall why I always leave it disabled. – converter42 Apr 20 '13 at 17:08
  • Doesn't work for me unfortunately. I'm using Ubuntu 13.10 and the latest version of the Citrix Receiver application. (USB-Keyboard / German Layout) – Stefan Brendle Feb 17 '14 at 18:37
2

Not sure what happens in your case, because I also use Citrix on Linux and all Ctrl keys work. One thing I know is that Ctrl-F2 sends the next key-stroke to the Linux host. So for instance if you use Gnome, you can minimize the Citrix window by typing Ctrl-F2 followed by Alt-F9 (which is the shortcut for minimizing windows in Linux).

  • Thank you for your response. Somehow that triggered in my mind to to check the mouse settings. See my answer for details. – Mark Porter Apr 8 '10 at 18:02
2

I have similar problem with Citrix ICA Client under Ubuntu 12.04 and Win7 as a remote system. But Mark's workaround didn't help to me.

I've solved this by changing ~/.ICAClient/wfclient.ini

Replace:

;KeyboardLayout = (User Profile)

By:

KeyboardLayout = US-International

I suppose that ICA client inadequately choose system keyboard layout, because I have bilingual system locale (EN+RU).

  • 1
    Combined with this answer, this allowed me to send Ctrl+Alt+Delete as well – dwurf Apr 3 '14 at 1:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.