1

Search Crawling is error out on my MOSS 2007 installation.

I get the following error for all the web apps I have following error in Crawl logs.

http://mysites.devserver URL could not be resolved. The host may be unavailable, or the proxy settings are not configured correctly on the index server.

The Application Event log also has the following corresponding error The start address http://mysites.devserver cannot be crawled.

Context: Application 'SSPMain', Catalog 'Portal_Content'

Details: The URL of the item could not be resolved. The repository might be unavailable, or the crawler proxy settings are not configured. To configure the crawler proxy settings, use the Proxy and Timeout page in search administration. (0x80041221)

I'm using Windows 2008 server. I tried accessing the site using the above mentioned url and its available. I did the registry setting for loop back issue found here http://support.microsoft.com/kb/896861 still not luck. Any Ideas?

  • Are you able to crawl the IP address? – Nat Mar 12 '10 at 6:10
  • have you extended your web application and or configured alternate access mappings? if so there is extra IIS stuff required. I don't know the fix but I know we ran into that and my engineer had to do some IIS changes to correct it. also maybe try this on sharepoint.stackexchange.com – Jordan W. Feb 17 '12 at 16:23
1

I had the exact same problem, you need to increase the connection timeout in the farm search administration screen, I change this on my VM from 60 seconds to 120 seconds and im now crawling content successfully.

  • Interestingly, this appears to have worked for me as well. I tried a number of things and was even able to browse to and access content using the same URL as the crawl, using the crawl account, but full crawls were still completing in ~20 seconds with a top level error. – bdimag Dec 2 '16 at 18:48
1

Try some basic network tests from the server doing the crawl. You need to try the following:

  • nslookup the fqdn and the hostname
  • ping the ip address returned from above
  • browse to the URL

This is just in case it is something simple - if you have a network issue with the crawl server then you won't get any further.

Check for any errors under Central Admin > Application Management > Check Services Enabled on this Farm - that should highlight any issues with SSPs etc.

Also check your server application logs, and Sharepoint ULS logs (Codeplex has a great Sharepoint Solution for this - LogViewer)

Also - can you specify a little more about your environment:

  • how many servers on farm? roles?
  • any network load balancing going on?
0

Check that the farm level search settings aren't set to use a proxy server, or if you need to use one, make sure the proxy server is correct.

  • No, I checked it, its set to not use proxy server. – Satish Mar 8 '10 at 14:32
0

This article might help to troubleshoot your issue..

http://kalashnikovtechnoblogs.blogspot.in/2012/02/troubleshooting-crawl-issues-for-ssl.html

Thanks, Kalashnikov http://kalashnikovtechnoblogs.blogspot.in

if it helps, Please dont forget to mark it as an answer. Thank you.

0

Or add your web app urls to server host files, that solved it for me.

0

Try telnet to the URL you are trying to crawl in your search service application. If it does not work. That is the issue.

IF you are able to telnet you will be able to crawl it.

Solution: Work with DNS team to make sure you are able to access the URL from search service

OR put host entry in the host file of search server and point to WFE and in the WFE go to firewall and add the PORT for web application to allow inbound communication.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.