2

Currently testing cobbler, but have problem with the kickstart script when the partition information is loaded.

Here is my ks: http://pastebin.ca/1824343

I can't figure out what is the problem with the partsection at all. Without it, it works. I've even tried autopart. If the entry is removed, it works, but of course I have to provide the installer with partition information.

Under the kickstart an python exception is raised. I get a Errno 2 No such file or directory. My Apache logs states:

File does not exist: /var/www/cobbler/links/CentOS-5.3-x86_64/images/updates.img

File does not exist: /var/www/cobbler/links/CentOS-5.3-x86_64/disc1

File does not exist: /var/www/cobbler/links/CentOS-5.3-x86_64/images/product.img

But without the part information, no error occours.

What am I not seeing?

Cobbler 2.0.3, imported the CentOS 5.3 x86_64 DVD, PXE booting from a Xen guest.

  • I think maybe I've found the answer. The initrd.img which is loaded after the inital tftp transfer, contains the disc1 reference which gets logged in apache error_log. Seems like the CentOS DVD is merged from all the CD iso´s, and maybe someone forgot to remove some references. I'll get back with more info :) – tore- Mar 6 '10 at 11:35
  • For other people, it might be related to cobbler issue #153 github.com/cobbler/cobbler/issues/153 – JavaRocky May 7 '12 at 7:01
0

I can't speak for CentOS but Red Hat Enterprise Linux will display a message on Virtual Console 3 (VT3) if there is a partitioning issue. Is there such a message?

0

I have no idea why I didn't work, but I started from scratch and built cobbler up again and now it works.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.