I've set up subversion on a CentOS fresh install. Web view works fine and gives no errors and requests password but when I try and access it through svn client (xcode) it gives the error 175011 (Repository has been moved).

I've tried some of the solutions out there but no success. My subversion.conf:

<Location /repos>
DAV svn
SVNParentPath /var/www/html/repos

# Limit write permission to list of valid users.
  # Require SSL connection for password protection.

  AuthType Basic
  AuthName "Authorization Realm"
  AuthUserFile /etc/svn-auth-conf
  Require valid-user

My Apache DocumentRoot: /var/www/html

I've only set up one svn repository so far so there shouldn't be any conflicts there. If you need any more info let me know.


  • Try changing <Location /repos> to <Location /repos/>. Also do the error occur on checkout or in an update ? (if its the later then perhaps you need to do a svn switch). – Lars Tackmann Mar 7 '10 at 14:41
  • Tried adding / to the location with no success, from memory it actually kills the webview. The error occurs when I try to connect to the repo from Xcode so presumably I won't be able to do either to it as the setup of the repo fails. I am using xcode to connect to another subversion and that works fine so its not xcode. – Rudiger Mar 8 '10 at 0:15

I don't know if this was a conflict with apache / subversion or some kind of bug but after placing the repo somewhere other than in /var/www/html/repos it works. I placed mine in /var/www/repos and used exactly the same config and it worked.

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.