I just finished setting up Windows 2003 Server on my new server, and I started setting up a RAID 5 for it.

I have 4x1TB Hard Drives. From MediaSheild RAID Utility (at boot time) the RAID size is displayed as 2.7TB. Linux also shows it as 2.7TB. However, in Windows, everything (including Windows Disk Management as well as Windows based MediaShield utility) is reporting only 760Gb.

I already tried converting partitioning table to GUID from MBR, because I read somewhere that Windows can only handle up to 2TB MBR tables, that didn't help much. Tried searching for partitioning utilities that I could use, but couldn't find anything free. Formatted the disk as NTFS partition from within Linux, it stop showing in Windows all together, even MediaShield windows utility isn't showing at anymore.

Windows is installed on a separate 500Gb hard drive, that's setup not to support RAID.
Any ideas?

Additional info:
I just deleted the RAID completely and created a new one. After booting into Windows, I verified that there are no partitions on the disk, and changed it into GPT from DISKPART. Here's a screenshot of what I'm seeing now. As you can see disk is reported as 746GB still, there is no active partitions on the disk, and it is a GPT partition table...

alt text http://www.freeimagehosting.net/uploads/4009c148bf.png

System specification:

  • Arima NM46X motherboard
  • Dual AMD Dual Core Opteron 2214 HE 2.2 Ghz
  • 4GB RAM
  • 4x1TB + 500GB HD
  • Running Windows Home Server SP2 (Windows 2003 Small Business Server SP2) x86

4 Answers 4


What happens when you create a smaller RAID volume? I had something similar when I was creating a RAID 5 for an ESX server. I had something like 4 or 5 TB of storage, but in the manager it only showed up as a few hundred GB. This was a while ago, and the details are hazy, but it was something along the lines of the fact that it only saw the remainder of the of the available space after the 2TB limit.

Try creating a RAID volume that's <= 2TB, and see if it shows up in disk manager, and report back. Also, like Romanov was asking, what SP level is your Windows installation at?

-- Yes, I know that ESX != Server 2003, but none of the other suggestions seem to have worked.

  • You are correct. I made a RAID5 array with only 3HDs and it shows up in Windows as 1.8Tb (correct size). So it seems that it does have something to do with 2Tb limitation. Here's a link that I found: forums.nvidia.com/index.php?showtopic=28866 Now I would like to know if it's somehow possible to bypass this limitation, or should I just send it all to hell and create a software RAID (since MediaShield is not a full hardware raid adapter, it just taxes south bridge (as far as I understand). Mar 13, 2010 at 19:52
  • Ok. I've looked at some of the links that you and others have provided, and dug around a little on my own. As best I can tell, there are a couple "problems" social.microsoft.com/Forums/en-US/whshardware/thread/… The guy doesn't seem to know if volumes >2TB is supported in WHS. In any case, he says RAID is "unsupported". Make of that what you will. Looking at the link you provided above, if it's true that the MediaShield is 32-bit, then you are SOL. There would be no way around that other than to get a different RAID controller. Mar 14, 2010 at 0:13
  • Ok, it looks like I'm out of luck, and I give up. I'll just create one RAID with 3 HDs in it (under 2Tb) and use 4-th HD as a stand-alone drive... Mar 16, 2010 at 15:44


Referencing MS large logical unit support FAQ and Windows GPT FAQ

You need Windows 2003 SP1 at least.

Per this article, you need to manually delete the partition you created on the storage drive (the 760 gb you see) and then convert the disk to GPT. You can do it through the disk management or using DISKPART utility. Then you should be able to create the required size (up to 256 tb) partition.

Good luck!


Ok, lets do this : Boot the server, destroy the array from the BIOS RAID config utility. Leave nothing, just RAID-enabled, but unassigned disks. Boot the server and create the array from the NVIDIA MediaShield control panel. Don't let the utility partition the array or anything. Then it should appear on your disk management screen as an unrecognized and uninitialized disk with the right size unallocated space.

In addition, if this doesn't work, a few more details on the system would be nice. what hardware are you running it on (BIOS/motherboard specifically), windows version and SP level.

p.s. In case you don't have it - MediaShield user guide and tech whitepaper

  • Added some info to the question and screenshot of disk manager. Problem is, I don't have partition to delete as you noted in the first part of your answer. Mar 13, 2010 at 3:31
  • @Ilya - Ok, i was convinced it's a windows problem but i ran a test on one our lab VMs and it worked perfectly, so the interaction of the mediaraid and windows is still suspect. I added a few ideas and requests to the answer.
    – V. Romanov
    Mar 13, 2010 at 7:34
  • I'll run this again from Windows utility, but the way windows media shield utility works is as soon as I create a new RAID, it starts to initialize it, which takes somewhere around 10 hours, and usually my Windows start blue-screening right after that... But I'll try it again now. Mar 13, 2010 at 17:41
  • Ok, it seems that Holocryptic and Helvick narrowed it down pretty well. I was a bit optimistic about the capabilities of the RAID controller. You could try setting the controller to present the disks as JBOD (no raid at all) and use windows software RAID.
    – V. Romanov
    Mar 14, 2010 at 12:49

Your clarification states that you are using Windows Home Server \ SBS 2003 SP2. Which one? AFAIK WHS uses a fairly intrusive drive extender that is probably causing you the problems you are seeing. There's a post here that explains how to manually override its default behaviour which as I understand it would cause the issues you are seeing.

This would probably get a better answer over at SuperUser where there are likely to be more WHS experts hanging out.

  • It's Windows Home Server, but Windows Home Server is an addon that runs on top of Windows 2003 SBS (that's why I put both, just in case). Mar 13, 2010 at 20:05
  • Fair enough - I thought WHS was more of a separate product. Anyway even a cursory search on the net throws up multiple references to the Drive extender not supporting >2TB volumes by default. Either present smaller volumes if your controller allows it or leave the RAID up to WHS which is what MS recommend, or (at your own risk) follow the instructions above.
    – Helvick
    Mar 13, 2010 at 20:47

Volumes larger than 2tb (as a single drive or through an array) must be set up with a GPT scheme, not MBR. MBR will only allow up to 2tb in total size. Also note that GPT can only be used as a boot OS drive if the motherboard supports EFI. If the motherboard does not have EFI then anything larger than 2tb cannot be used for booting. It can be used for storage, sizes up to 18 exabytes are supported.

As for WHS it is a separate product, not retail one. It's intended to be sold to OEMs that will install it on a machine designed for it's use.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.