After following this guide and connecting to the VPN Server, I get the following error:

Sat Mar 06 19:43:08 2010 us=127000 NOTE: failed to obtain options consistency info from peer -- this could occur if the remote peer is running a version of OpenVPN before 1.5-beta8 or if there is a network connectivity problem, and will not necessarily prevent OpenVPN from running (0 bytes received from peer, 0 bytes authenticated data channel traffic) -- you can disable the options consistency check with --disable-occ.

I am using Archlinux and installed openvpn with Pacman.

I want to acheive the following: Connect to the VPN Server, being able to route certain made up hosts through it.

Is this possible?

openvpn --version gives me the following

openvpn --version
OpenVPN 2.1.1 i686-pc-linux-gnu [SSL] [LZO2] [EPOLL] built on Jan 31 2010
Originally developed by James Yonan
Copyright (C) 2002-2009 OpenVPN Technologies, Inc. <[email protected]>


2 Answers 2


That guide is flawed, it has the wrong port on the client config, they should both be 1194.

You should fix that, and then run

tcpdump -n port 1194

on the server to verify that packets from the client are even reaching the server.

  • Ok well that solved the connection problem, but how do I connect to things using that tunnel? Like RDP ? Mar 6, 2010 at 22:41
  • Also, would this setup allow computers in the VPN-network to communicate? Mar 6, 2010 at 23:31
  • 1
    @Filip Ekberg, you should probably consider re-asking a followup question about OpenVPN routing. Include some details like IP addresses route tables and a copy of the openvpn config for both yoru client and server. Yes, computers connected via VPN may be able to contact each other. It depends on how you have configured openvpn.
    – Zoredache
    Mar 8, 2010 at 1:48
  • yeah, i'd say this issue is resolved, and rather than complicate it by trying to shoehorn the 2nd problem into it, you should make another question about routing/bridging and include all the relevant info.
    – Justin
    Mar 8, 2010 at 1:56

I used another guide and had the same error message. In the first step I could assure that packets are arriving at the server (by using tcpdump). The verbose log files stated that after some received packets there were no more received.

At the end the firewall on the server was the problem. This firewall was blocking packets in iptables FORWARD chain. Therefore all packets which were addressed directly to the firewall (external ip) could be processed but packets in the tunnel were blocked because these are handled by FOWARD chain.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .